Results 1 to 2 of 2
  1. #1
    jon80's Avatar
    jon80 is offline Senior Member
    Join Date
    Feb 2008
    Location
    Malta (EU)
    Posts
    213
    Rep Power
    10

    Default Assertions on Eclipse

    Any idea how to enable assertions on Eclipse, pls?

    No help found so far from Eclipse forum and on help...

  2. #2
    danielstoner's Avatar
    danielstoner is offline Senior Member
    Join Date
    Apr 2008
    Location
    Canada
    Posts
    191
    Rep Power
    10

    Default

    You have to do two things:
    - set the compiler compliance to at least 1.4 (Window/Preferences/Java/Compiler)
    - when you run the code pass the -ea parameter to the JVM (Run/Open Run Dialog/Arguments/VM Arguments
    Daniel @ [www.littletutorials.com]
    Language is froth on the surface of thought

Similar Threads

  1. New to eclipse..need some help
    By sireesha in forum Eclipse
    Replies: 3
    Last Post: 04-04-2008, 08:23 PM
  2. Eclipse GUI
    By XiaoXiao in forum Eclipse
    Replies: 0
    Last Post: 01-23-2008, 11:55 AM
  3. SDE for Eclipse 4.1 sp1
    By JavaBean in forum Java Software
    Replies: 0
    Last Post: 10-04-2007, 09:13 PM
  4. SDE for Eclipse 4.1
    By levent in forum Java Software
    Replies: 0
    Last Post: 08-04-2007, 07:47 PM
  5. SDE for Eclipse 4.0 SP2
    By levent in forum Java Software
    Replies: 0
    Last Post: 05-15-2007, 05:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •