Im new to java programming but i know most the basics of it. I wanted to start making a basic game so tried to use the Display() function (from LWJGL) to make a window appear. I then wrote a separate class called gameLoop with the functions gameLoop.start() to create the window, then update the display at 50fps and gameLoop.stop() to stop the loop and close the window. The problem is that a window never opens and i get the same error each time. :

Exception in thread "main" java.lang.NoSuchMethodError: getPointer
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1827)
at java.lang.ClassLoader.loadLibrary( :1742)
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at org.lwjgl.Sys$
at Method)
at org.lwjgl.Sys.doLoadLibrary(
at org.lwjgl.Sys.loadLibrary(
at org.lwjgl.Sys.<clinit>(
at org.lwjgl.opengl.Display.<clinit>( )
at org.newdawn.slick.AppGameContainer$
at Method)
at org.newdawn.slick.AppGameContainer.<clinit>(AppGam
at org.newdawn.slick.tests.AlphaMapTest.main(AlphaMap

This is the display class, in the future it will also stop the display using gameLoop.stop(), but at the moment i want the display to be on until i stop it using stop in eclipse.
Java Code:
public class Display {
	public static void main() {

The gameLoop class.
Java Code:
import org.lwjgl.opengl.Display;
import org.lwjgl.opengl.DisplayMode;

public class gameLoop {
	public static int i = 0;
	public static void start(){
		try {
		Display.setDisplayMode(new DisplayMode(800,600)); //creates the display
		}catch(Exception e) {}
		int i = 0;
		while (i < 1) { //infinite loop intended, the function end sets i =1
			try {
				Thread.sleep(20); //updates display at 50fps
			}catch(Exception e) {}

	public static void end() {
		gameLoop.i = 1;
Any help would be greatly appreciated.