I have a small application written in Java on Windows and compiled with Java 1.6. It works fine on Windows. But when I bring it over to my Mac, the application cannot be run. I keep getting a InvocationTargetException error on the console every time when I try to run it:

Java Code:
Exception in thread "main" java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
Caused by: java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:197)
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
	at org.eclipse.swt.internal.C.<clinit>(C.java:21)
	at org.eclipse.swt.widgets.Display.<clinit>(Display.java:138)
I tried compiling my application in Java 1. 5 instead but I still get the same problem. I also tried to set the default Java AVM on my Mac to 1. 5 and 1.6 but both versions didn't work either. I am running on Mac OS X 1.5.8
I totally have no idea what's wrong since the application runs perfectly fine on my Windows machine.

Thanks for any help.