Results 1 to 2 of 2
  1. #1
    futuros's Avatar
    futuros is offline Member
    Join Date
    Mar 2011
    Rep Power

    Default The type XX cannot be resolved. It is indirectly referenced from required .class file

    Dear sirs,

    I have downloaded Java examples which use JAVA API for Allegrograh (A Semantic Web database) . However, when I run the examples as Java Application (within Eclipse), they work, but when I had tried to rewrite one to a Java bean that runs on Tomcat server, I get follow error:

    An error occurred at line: 9 in the jsp file: /search.jsp
    The type com.franz.agbase.AllegroGraphException cannot be resolved. It is indirectly referenced from required .class files

    It seems that all classpaths are setted correctly, because application works in Java Application mode. Maybe it is necessary to set some configurations for a server mode. ????

    Thank you a lot of for your help.
    with regards
    Miroslav Líška
    Last edited by futuros; 03-11-2011 at 07:58 AM.

  2. #2
    Tolls is offline Moderator
    Join Date
    Apr 2009
    Rep Power


    Your eclipse may be working, but I'm guessing when you deploy the code to Tomcat you haven't deployed all the dependent jar files.

Similar Threads

  1. HttpServlet Cannot be resolved to a type
    By chizbox in forum Eclipse
    Replies: 3
    Last Post: 07-01-2012, 05:09 PM
  2. Replies: 4
    Last Post: 12-13-2010, 10:00 PM
  3. Filter cannot be resolved to a type??
    By Harrie_KalaChakra in forum Eclipse
    Replies: 1
    Last Post: 01-15-2010, 09:19 AM
  4. Replies: 4
    Last Post: 11-25-2008, 05:53 AM
  5. Replies: 1
    Last Post: 12-18-2007, 10:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts