Results 1 to 1 of 1
  1. #1
    Join Date
    Jan 2011
    Rep Power

    Default Resources load in Eclipse but not in standalone .jar

    SOLVED: Heh, solved my own problem. Turns out Eclipse is a lot more lax with filenames than the java interpreter, my mis-capitalized PNG/png was tripping it up.

    When I export my project to a .jar, it suddenly has difficulty loading resources.

    This is what my file tree looks like:

    The code that loads the image, inside of

    The program runs fine inside of eclipse, but when I export it and try to run it standalone, it can't find that png. I unzipped the jar and looked inside and cube.png was sitting there in the root right where I thought it should be. Can anyone help me with getting it shifted to wherever it needs to be?
    Last edited by leonsbuddydave; 01-14-2011 at 06:11 AM.

Similar Threads

  1. Replies: 0
    Last Post: 08-13-2010, 11:52 AM
  2. Standalone applications
    By sachin2 in forum New To Java
    Replies: 0
    Last Post: 07-21-2009, 09:08 PM
  3. External runtime resources access in Eclipse
    By batkins61 in forum Eclipse
    Replies: 0
    Last Post: 01-07-2009, 06:42 PM
  4. Eclipse load issue with Fedora Core 9
    By digilogik in forum Eclipse
    Replies: 2
    Last Post: 11-01-2008, 06:22 AM
  5. Can not load image in SWT/Eclipse
    By janice in forum SWT / JFace
    Replies: 4
    Last Post: 10-03-2008, 05:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts