Results 1 to 3 of 3
  1. #1
    J_a_y is offline Member
    Join Date
    Aug 2007
    Rep Power

    Default java.lang.NoClassDefFoundError

    Hi Guys,

    We have just upgraded the JRE to ver1.5.09 on all machines. Unfortunately, this has caused an applet on one specific site not to work any more. Ordinarily we would just downgrade the JRE to the previous version which we know worked or, failing that, simply reghost the machine.

    The problem is that one particular machine, one of our many HP Compaq DC7100 workstations, has decided not to play along. The last stable version installed was which worked with out webEIS site. However, since upgrading to 1.5 the user has had problems. Even after ghosting the PC with the last installed version of JRE1.4.1.05 the webEIS applet will not run. It comes up with java.lang.NoClassDefFoundError

    I have tried everything I can think of - both with and without the MSJVM. I've tried upgrading to the latest JRE 6.0.02. I've tried a clean install of each of the JRE versions so that is the only version installed. No luck. I've checked the JAVA_HOME which looks okay. Everything else I found on the web relates to this error when developing your own applet however this is not the case and nothing on the site has been changed.

    The problem PC in question is XP SP2 however we are also able to replicate this problem on XP SP1. Below is the Java console log:

    java.lang.NoClassDefFoundError: com/sas/apps/webEIS/viewer/DataPlayerApplet
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at n Source)
    at Source)
    at$100(Unknown Source)
    at$ Source)
    at Method)
    at Source)
    at sun.applet.AppletClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.applet.AppletClassLoader.loadCode(Unknown Source)
    at sun.applet.AppletPanel.createApplet(Unknown Source)
    at sun.plugin.AppletViewer.createApplet(Unknown Source)
    at sun.applet.AppletPanel.runLoader(Unknown Source)
    at Source)
    at Source)

    Any help on this issue would be greatly appreciated.
    Many thanks in advance,
    Last edited by J_a_y; 08-02-2007 at 12:51 PM. Reason: typo

  2. #2
    levent Guest


    Hi Jay,

    Did you know/check where is this class: com/sas/apps/webEIS/viewer/DataPlayerApplet

    The JVM can not find this class. In your previous installation, it might have been copied to JRE_PATH/lib/ext directory. If you copy the jar containing this class to classpath, your applet should work.

  3. #3
    J_a_y is offline Member
    Join Date
    Aug 2007
    Rep Power

    Cool Problem solved.

    Hi Levent,

    Many thanks for the info. I finally found out who is "in charge" of the site. And that there are, in fact, several files that are meant to be copied into the /lib/ext directory.

    Unfortunately, it still won't work with JRE 1.5.x but at least now we have a workaround for when the workaround (downgrading JRE) doesn't immediately work.


Similar Threads

  1. Replies: 2
    Last Post: 01-20-2014, 07:45 AM
  2. Replies: 2
    Last Post: 07-21-2012, 01:15 AM
  3. java.lang.NoClassDefFoundError:
    By hawkeye in forum Enterprise JavaBeans (EJB)
    Replies: 1
    Last Post: 06-16-2008, 10:56 AM
  4. java.lang.NoClassDefFoundError
    By fred in forum Advanced Java
    Replies: 3
    Last Post: 08-01-2007, 05:00 PM
  5. Replies: 2
    Last Post: 08-01-2007, 05:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts