Hello everyone,

Recently Java Updater attempted to upgrade my installation from Java to 6.17 to 6.18. I stopped it halway through the upgrade because it needed to shutdown a running program and I did not want to loose any of the work I had within the program. I eventually finished what I was doing, terminated the program and restarted my computer at which time Java said it would complete the upgrade. Everything seemed to work fine but the problems began when I went to Settings -> Contol Panel -> Java and instead of the Java Control Panel appearing the following dialog box appeared with "Java Virtual Machine Launcher" in the Title Bar and an error message of "Could not find the main class. Program will exit."

I have uninstalled and reinstalled various versions of Java 6 with no luck. Version 5.xx brings up a working Control Panel but some of my software needs version 6.15 at least. I have run a few registry cleaners as well as Microsoft's Windows Installer CleanUp Utility to catch broken associations, etc but nothing has worked yet to get a normal installation of 6.18 with working Java Control Panel. In addition I tried various Restore Points but whenever I tried to bring the version of Jave to a 6.xx level the error message would reappper and the Java software quit working, although Windows Task Manager does show javaw.exe running when I attempt to start a Java program, otherwise there is just jqs.exe and jusched.exe running in the backgraound.

I am running XP SP3 and Firefox 3.6. The Java Verification Page ( Verify Java Version ) properly detects Java 6.18 on my computer but the "How do I test whether Java is working on my computer?" site ( How do I test whether Java is working on my computer? ) does not properly run the applet (just a black rectangle appears), this after clearing my browser cache.

The Tools -> Java Console selection in Firefox brings up no console but the Error Console has a messages, two of them below:
Error: [Exception... "'JavaScript component does not have a method named: "onLocationChange"' when calling method: [nsIWebProgressListener::onLocationChange]" nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsBrowserContentHandler.js :: openWindow :: line 167" data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsBrowserContentHandler.js
Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.clearUserPref]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://dotnetassistant/content/bootstrap.js :: BootStrapDotNetAsssitantExtension :: line 52" data: no]

I hope you developers won't mind this non-programming question but I am not sure where else to turn for a broken Java installation problem. Google searches bring me here to these forums, hopefully someone can help me fix this situation.

Thanks, Steve