Results 1 to 2 of 2
  1. #1
    PaulBinni is offline Member
    Join Date
    Nov 2009
    Rep Power

    Default Java not recognizing UNIX secondary group

    I'm seeing the following problem and I think it is related to java bug 4052517

    I have a directory called test. the ownership of that directory belongs to the 'aa' group.
    I have a user junioradm whose primary group is 'adm' but is also a member of the 'aa' group.

    I'm executing a java program as the junioradm user. The program is supposed to create directories in the test directory.
    When I run the program mkdir() is returning false. If I change the group owner of the test directory to 'adm' the program executes fine.

    The problem seems to be that java does not recognise that ‘junioradm’ is a member of the ‘aa’ group and will not create the directories because of this.

    Has anyone seen this problem before or encountered bug 4052517? Is there any known solution?

  2. #2
    venkat180 is offline Member
    Join Date
    Nov 2009
    Rep Power


    I am also facing the problem. I tried executing Runtime command, but no luck.

    Tried fileObj.mkdir() as well.

    Any solution for this ?


Similar Threads

  1. Netbeans not recognizing library
    By ehsen in forum NetBeans
    Replies: 16
    Last Post: 08-30-2009, 05:32 PM
  2. Replies: 6
    Last Post: 07-10-2008, 07:28 PM
  3. how to run java app on windows in a cron like on unix
    By rockie12 in forum Advanced Java
    Replies: 7
    Last Post: 05-23-2008, 01:39 PM
  4. using java to login to unix
    By dowell in forum Advanced Java
    Replies: 4
    Last Post: 05-23-2008, 07:26 AM
  5. changing the secondary ID of a view
    By schuetzejanett in forum SWT / JFace
    Replies: 0
    Last Post: 08-08-2007, 07:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts