Results 1 to 2 of 2
  1. #1
    onetech is offline Member
    Join Date
    Jan 2015
    Posts
    2
    Rep Power
    0

    Default Servlets not executing:404 error using eclipse+maven+tomcat

    Hi,

    I am working on eclipse with maven. I created a maven web project and deployed it. Problem here is : jsp page works fine but the servlet do not execute at all.
    Servlet name : Other
    Error:

    Jun 15, 2015 5:32:19 PM org.apache.catalina.core.StandardWrapperValve invoke
    SEVERE: Allocate exception for servlet Other
    java.lang.ClassNotFoundException: controller.Other
    at org.apache.catalina.loader.WebappClassLoader.loadC lass(WebappClassLoader.java:1680)
    at org.apache.catalina.loader.WebappClassLoader.loadC lass(WebappClassLoader.java:1526)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1128)
    at org.apache.catalina.core.StandardWrapper.allocate( StandardWrapper.java:827)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:129)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:191)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:103)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:293)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:861)
    at org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.process(Http11Protocol.java:606)
    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run( JIoEndpoint.java:489)
    at java.lang.Thread.run(Unknown Source)


    Also, one thing, are the servlets getting converted to .class file. How to check it?
    Any solution please.

  2. #2
    gimbal2 is offline Just a guy
    Join Date
    Jun 2013
    Location
    Netherlands
    Posts
    5,114
    Rep Power
    12

    Default Re: Servlets not executing:404 error using eclipse+maven+tomcat

    Eclipse deploys the application somewhere to a server; you can generally find out where by double clicking your server runtime instance in the 'servers' view. Check to see that the servlet class is actually there in the WEB-INF/classes/controller folder.

    It is not of course, or you wouldn't get the 'classnotfound' error. Are you sure you have a servlet class 'Other' in a package 'controller' ?
    "Syntactic sugar causes cancer of the semicolon." -- Alan Perlis

Similar Threads

  1. Replies: 1
    Last Post: 09-03-2013, 12:54 PM
  2. Servlets/JSP Tomcat Eclipse
    By rookiecoder in forum Java Servlet
    Replies: 1
    Last Post: 11-05-2012, 10:52 AM
  3. Error executing Eclipse Juno on Fedora 16
    By jfabian in forum Eclipse
    Replies: 0
    Last Post: 07-16-2012, 04:03 AM
  4. Error while executing java file in eclipse
    By kutty in forum New To Java
    Replies: 0
    Last Post: 10-20-2010, 01:14 PM
  5. error Tomcat in eclipse
    By Marty in forum Eclipse
    Replies: 1
    Last Post: 05-06-2007, 04:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •