Results 1 to 1 of 1
  1. #1
    benartiss is offline Member
    Join Date
    Dec 2010
    Rep Power

    Default Applet works in a subfolder but not in root?

    Hi everyone,

    I'm having a bit of grief with using the PTViewer applet. It's something we use a lot - usually problem free - but when it came to doing our own website it works in the development environment (just a subfolder in the website root called "2010") but when we went live it just won't work!

    The code between all websites is always exactly the same, it was literally a copy and paste job which is why I can't understand why it's not working. I get the error:

    Java Code:
    exception: java.lang.NullPointerException
    If I fiddle about with the "code"/"archive" attributes it just fails to load. I read somewhere about the "codebase" tag helping but we've not used it on any of the other websites and it made no difference. I also tried moving the ptviewer.jar file into the same directory as the images but to no avail.

    I've tried everything I can think of. Has anyone else come across a similar problem? Any help would be greatly appreciated!


    P.S. I forgot to mention: if I use the ptviewer.jar file from a different server it successfully loads the applet but only shows a red box (I'm guessing because the images are not on the same server)
    Last edited by benartiss; 12-07-2010 at 05:03 PM.

Similar Threads

  1. APPLET dosen't works in HTML
    By coolest-for_you in forum Java Applets
    Replies: 0
    Last Post: 12-20-2009, 07:14 PM
  2. root directory
    By raghu9198 in forum New To Java
    Replies: 19
    Last Post: 01-06-2009, 04:11 AM
  3. Replies: 6
    Last Post: 10-22-2008, 06:05 PM
  4. Signed applet works only with jre 1.6u10 beta...
    By smartizzz in forum Java Applets
    Replies: 0
    Last Post: 08-07-2008, 08:54 AM
  5. Context Root change
    By rvasu_77 in forum Advanced Java
    Replies: 2
    Last Post: 07-12-2007, 11:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts