I am developing a Java GUI Applet application and aiming to make it available to as many OS's as possible. So far, the applet runs fine on most OS's (Linux like Ubuntu, Centos, then Windows Vista, XP, etc...). The only system that refuses to load the applet is MAC. It doesn't show any errors. Just a blank page.

I've been discussing this problem in Sun's forum but so far the problem hasn't been resolved. And it's been a while since I got a response in the Sun's forum so I thought I should ask in another forum. Here's the link to the thread on Sun's forum:

http*remove this*://forums.sun.*remove this*com/thread.jspa?threadID=5401288&tstart=0

(Sorry, I still can't post any links.)

What I tried to do in order to make it work was to printStackTraces() everywhere to see if there's any errors but still no result.

Then I was suggested to recompile my application with JRE5, so I did but it still doesn't work. I'm not sure if I'm doing it wrong, here's a line in my bat file - this is how I compile my java files:

Java Code:
javac -classpath "lib/commons-math-1.2.jar;lib/jfreechart-1.0.13.jar;lib/jcommon-1.0.16.jar" -target 1.5 util/*.java