Results 1 to 3 of 3
  1. #1
    FakeRabbit is offline Member
    Join Date
    Sep 2008
    Rep Power

    Default bundles not resolved

    Hello everyone.

    I'm pretty new to java and I've been asked to do some minor changes in a project that is already finished. Problem is I can't really get it to run from the sources I've been provided with and can't contact the author to get some feedback.
    As far as my limited java experience is telling me, it's an OSGI application with of 3 bundles:

    When I try to run it, I can see the splash screen for a while, but then an error appears. In the error log I can see the following:

    One or more bundles are not resolved because the following root constraints are not resolved:

    Bundle reference:file:/D:/Programy/eclipse/workspace/core/ was not resolved.

    Missing imported package taaccess_0.0.0.
    Missing imported package tities_0.0.0.
    Missing imported package pping_0.0.0.
    Missing imported package _0.0.0.
    Missing required bundle 0.0.
    Missing required bundle
    Now, I imagine there's something wrong with run configurations, project properties or there's an eclipse plugin I'm missing but as I have no experience in OSGI apps, I'm running in the dark here.
    I tried selecting the right bundles in "project references" in projects properties.
    Also tried selecting plugins in run configuration - there are some effects, but they are usually giving me more errors like those above.

    Any help would be appreciated. If there's any additional info you need, let me know where to find it and I'll provide :)
    Thanks in advance!

  2. #2
    DarrylBurke's Avatar
    DarrylBurke is offline Forum Police
    Join Date
    Sep 2008
    Madgaon, Goa, India
    Rep Power

    Default Re: bundles not resolved

    Looks like an Eclipse-specific problem. Moving from New to Java.

    If you're forever cleaning cobwebs, it's time to get rid of the spiders.

  3. #3
    FakeRabbit is offline Member
    Join Date
    Sep 2008
    Rep Power

    Default Re: bundles not resolved

    Can anyone help me with this? Sorry for bumping an old thread but I'm really stuck here :(

Similar Threads

  1. dataInputStream cannot be resolved in GUI class
    By tmboredi in forum New To Java
    Replies: 12
    Last Post: 01-13-2012, 04:33 PM
  2. canvasObject cannot be resolved.
    By falconfetus8 in forum New To Java
    Replies: 10
    Last Post: 12-31-2011, 12:42 AM
  3. Array cannot be resolved
    By aqeel2010 in forum New To Java
    Replies: 4
    Last Post: 10-07-2011, 06:38 PM
  4. HttpServletRequest cannot be resolved-- Help me
    By hphuoc in forum Java Servlet
    Replies: 1
    Last Post: 04-26-2011, 09:23 AM
  5. HibernateUtil cannot be resolved
    By fierof2 in forum Advanced Java
    Replies: 14
    Last Post: 02-01-2011, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts