I have some experience with Java, started with eclipse a couple months ago. I've inherited a project from someone who is no longer available. Things have been going well, able to edit and recompile without problem. Today for the first time I added a new class to the project but must have done something wrong. When I try to run, eclipse says there are errors. When I go the the hierarchy I see red X at the project/package level, but all .java source files in that package look fine (no red x). If I try to run, I get message that main class file can't be found. I checked the .bin folder, and discovered all the .class files were gone. I tried to 'build all' but that doesn't help. I tried running 'clean up', which deleted all the folders under the .bin folder (.bin top level folder is still there). Then 'build all' still didn't recreate the .bin folders or .class files. When I went to a different project, edited a file and saved it, all the .class files for that project were deleted also, and that project now has a red x. Now I can't compile or run anything. It does seem to know that the files in the project are consistent; it will flag an error if a class in one file doesn't exist in another. Any help greatly appreciated.