I am trying to run eclipse galileo on 32 bits windows 7, everything works fine except the debugger. I tried the following steps as well but it did not work.

Steps I tried:
1")Switched off the Zone Alarm Firewall
2) Switched off my Norton Internet Security suite
3) Switched off the UAC
4) Started eclipse with"Run as an Administrator" option

I got the following error trace.

Error trace:
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product

Mon May 02 16:23:16 IST 2011
Cannot find a free socket for the debugger

I also tried re-installing Eclipse. This time I installed Eclipse Helios SR-1. I tested debugging my project, it worked. We use SVN as repository in my company. So I went ahead and installed the SVN plugins and connector. After linking the code to SVN, if I try to run my debugger now, I get the same error back "cannot find a free socket for debugger".

Any help would be appreciated