Results 1 to 13 of 13
  1. #1
    Marty is offline Member
    Join Date
    May 2007
    Rep Power

    Default EXCEPTION_ACCESS_VIOLATION (0xc0000005)

    Hello, this error appeared in the console.

    # An unexpected error has been detected by HotSpot Virtual Machine:
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x7c911010, pid=3244, tid=280
    # Java VM: Java HotSpot(TM) Client VM (1.5.0_02-b09 mixed mode, sharing)
    # Problematic frame:
    # C [ntdll.dll+0x1010]
    # An error report file with more information is saved as hs_err_pid3244.log
    # If you would like to submit a bug report, please visit:
    # HotSpot Virtual Machine Error Reporting Page

    what is happening?

  2. #2
    levent Guest


    When does this happen? What kind of application are you using (is this a JNI project?)? This is a JVM crash. This happens in native part of the JVM and i dont think there is anything you can do.

    Does this happen frequently?

  3. #3
    Alan is offline Member
    Join Date
    May 2007
    Rep Power


    I have seen this before
    I resolved it reinstalling the VM

  4. #4
    pegitha is offline Member
    Join Date
    Apr 2007
    Rep Power

  5. #5
    lalit_addhu is offline Member
    Join Date
    Oct 2008
    Rep Power

    Question EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x7c82f585, pid=8864, tid=9196

    I am facing almost the same problem. I am using Java 1.4.2_13 version on Windows 2003 Server R2. The Problem is I get this kind of log messages everyday almost:

    # An error report file with more information is saved as hs_err_pid8864.log
    # An unexpected error has been detected by HotSpot Virtual Machine:
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x7c82f585, pid=8864, tid=9196
    # Java VM: Java HotSpot(TM) Server VM (1.4.2_13-b06 mixed mode)
    # Problematic frame:
    # C [ntdll.dll+0x2f585]

    --------------- T H R E A D ---------------

    Current thread (0x009cf960): VMThread [id=9196]

    siginfo: ExceptionCode=0xc0000005, reading address 0x00000004

    EAX=0x072c3a40, EBX=0x06960000, ECX=0x0696d578, EDX=0x00000000
    ESP=0x03cdfab4, EBP=0x03cdfac0, ESI=0x072c3a38, EDI=0x072c2df0
    EIP=0x7c82f585, EFLAGS=0x00010283

    Top of Stack: (sp=0x03cdfab4)
    0x03cdfab4: 06960000 072c3920 00000000 03cdfba8
    0x03cdfac4: 7c82ff8a 0a533e50 06962aa0 03cdfb88
    0x03cdfad4: 00000000 072c3928 072c3928 072b5ba0
    0x03cdfae4: 00000000 03cdfad8 095d7d90 03cdfc7c
    0x03cdfaf4: 071c71ac 07220770 ffffffff 071c9835
    0x03cdfb04: 071c9852 00000078 071c987d 00000078
    0x03cdfb14: 00000000 07176f3a 00000078 095d7dbc
    0x03cdfb24: 095d7d90 07ef0000 00000000 099a3f88

    Instructions: (pc=0x7c82f585)
    0x7c82f575: 6a 00 00 8b 4e 0c 8d 46 08 8b 10 89 4d 0c 8b 09
    0x7c82f585: 3b 4a 04 89 55 14 0f 85 39 05 03 00 3b c8 0f 85

    Stack: [0x03ca0000,0x03ce0000), sp=0x03cdfab4, free space=254k
    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
    C [ntdll.dll+0x2f585]
    C [ntdll.dll+0x2ff8a]
    C [aamapi50.dll+0x2f75a1]

    VM_Operation (0x0007f520): exit, mode: safepoint, requested by thread 0x000370a0

    --------------- P R O C E S S ---------------

    Java Threads: ( => current thread )
    0x04ddc998 JavaThread "Trigger Input Control TimerDaemon" daemon [_thread_blocked, id=4556]
    0x053d9de0 JavaThread "User Tasks" [_thread_blocked, id=8024]
    0x045dc228 JavaThread "HTTPListener@5555" [_thread_in_native, id=10116]
    0x042ed008 JavaThread "User Tasks Pool4" [_thread_blocked, id=8264]
    0x04a04b48 JavaThread "User Tasks Pool3" [_thread_blocked, id=3844]
    0x04a04538 JavaThread "Event Manager Thread" [_thread_blocked, id=10028]
    0x04551b90 JavaThread "Event Manager Thread" [_thread_blocked, id=8488]
    0x045519c8 JavaThread "ISM Log Thread" [_thread_blocked, id=4416]
    0x046e4e58 JavaThread "TS-EventHandler" daemon [_thread_blocked, id=8424]
    0x04963e78 JavaThread "TS-TimeoutMgr" daemon [_thread_blocked, id=5016]
    0x04af6008 JavaThread "webM IS Cache Manager" daemon [_thread_blocked, id=5868]
    0x04329cb0 JavaThread "Thread Pool Sensor" daemon [_thread_blocked, id=6864]
    0x04329b48 JavaThread "HTTP Handler" [_thread_in_native, id=6256]
    0x043295e0 JavaThread "HTTP Handler" [_thread_in_native, id=9600]
    0x00a04ad0 JavaThread "HTTP Handler" [_thread_in_native, id=8200]
    0x00a04968 JavaThread "Service Thread Pool" [_thread_blocked, id=9844]
    0x04b0c870 JavaThread "Service Thread Pool" [_thread_blocked, id=4408]
    0x04b0c708 JavaThread "Service Thread Pool" [_thread_blocked, id=9536]
    0x04753868 JavaThread "Service Thread Pool" [_thread_blocked, id=9780]
    0x04753700 JavaThread "Service Thread Pool" [_thread_blocked, id=6472]
    0x0492eb10 JavaThread "Service Thread Pool" [_thread_blocked, id=8840]
    0x0492e9a8 JavaThread "Service Thread Pool" [_thread_blocked, id=7616]
    0x041355f8 JavaThread "Thread-11" daemon [_thread_blocked, id=3172]
    0x048280a0 JavaThread "Thread-9" daemon [_thread_blocked, id=9640]
    0x04231920 JavaThread "Thread-8" daemon [_thread_blocked, id=10180]
    0x04541e78 JavaThread "TxnData-Deadlock-Manager" daemon [_thread_blocked, id=3076]
    0x0465fbc0 JavaThread "Thread-2" daemon [_thread_blocked, id=8812]
    0x03f996d0 JavaThread "Cron Daemon" [_thread_blocked, id=8584]
    0x03f99568 JavaThread "Cron Daemon Pool2" [_thread_blocked, id=6408]
    0x03f0d640 JavaThread "Cron Daemon Pool1" [_thread_blocked, id=6636]
    0x00a3a0f0 JavaThread "CompilerThread1" daemon [_thread_blocked, id=9012]
    0x00a390b0 JavaThread "CompilerThread0" daemon [_thread_blocked, id=9920]
    0x00a38358 JavaThread "AdapterThread" daemon [_thread_blocked, id=9464]
    0x009d0e60 JavaThread "Finalizer" daemon [_thread_blocked, id=8652]
    0x009d02d0 JavaThread "Reference Handler" daemon [_thread_blocked, id=9256]
    0x000370a0 JavaThread "main" [_thread_blocked, id=9420]

    Other Threads:
    =>0x009cf960 VMThread [id=9196]

    VM state:at safepoint (shutting down)

    VM Mutex/Monitor currently owned by a thread: ([mutex/lock_event])
    [0x000367e0/0x0000071c] Threads_lock - owner thread: 0x009cf960

    def new generation total 26240K, used 15591K [0x10010000, 0x11c80000, 0x138f0000)
    eden space 23360K, 55% used [0x10010000, 0x10cad6b0, 0x116e0000)
    from space 2880K, 92% used [0x116e0000, 0x1197c728, 0x119b0000)
    to space 2880K, 0% used [0x119b0000, 0x119b0000, 0x11c80000)
    tenured generation total 233024K, used 55015K [0x138f0000, 0x21c80000, 0x30010000)
    the space 233024K, 23% used [0x138f0000, 0x16ea9de0, 0x16ea9e00, 0x21c80000)
    compacting perm gen total 16384K, used 16345K [0x30010000, 0x31010000, 0x34010000)
    the space 16384K, 99% used [0x30010000, 0x310064c8, 0x31006600, 0x31010000)

    Dynamic libraries:
    0x00400000 - 0x0040b000 E:\Apps\Java\j2sdk1.4.2\jre\bin\java.exe
    0x7c800000 - 0x7c8c0000 C:\WINDOWS\system32\ntdll.dll
    0x77e40000 - 0x77f42000 C:\WINDOWS\system32\kernel32.dll
    0x77f50000 - 0x77fec000 C:\WINDOWS\system32\ADVAPI32.dll
    0x77c50000 - 0x77cef000 C:\WINDOWS\system32\RPCRT4.dll
    0x77ba0000 - 0x77bfa000 C:\WINDOWS\system32\MSVCRT.dll
    0x08000000 - 0x082bb000 E:\Apps\Java\j2sdk1.4.2\jre\bin\server\jvm.dll
    0x77380000 - 0x77412000 C:\WINDOWS\system32\USER32.dll
    0x77c00000 - 0x77c49000 C:\WINDOWS\system32\GDI32.dll
    0x76aa0000 - 0x76acd000 C:\WINDOWS\system32\WINMM.dll
    0x71bc0000 - 0x71bc8000 C:\WINDOWS\system32\rdpsnd.dll
    0x771f0000 - 0x77201000 C:\WINDOWS\system32\WINSTA.dll
    0x71c40000 - 0x71c98000 C:\WINDOWS\system32\NETAPI32.dll
    0x76b70000 - 0x76b7b000 C:\WINDOWS\system32\PSAPI.DLL
    0x10000000 - 0x10007000 E:\Apps\Java\j2sdk1.4.2\jre\bin\hpi.dll
    0x76f50000 - 0x76f63000 C:\WINDOWS\system32\Secur32.dll
    0x00380000 - 0x0038e000 E:\Apps\Java\j2sdk1.4.2\jre\bin\verify.dll
    0x00390000 - 0x003a9000 E:\Apps\Java\j2sdk1.4.2\jre\bin\java.dll
    0x003c0000 - 0x003ce000 E:\Apps\Java\j2sdk1.4.2\jre\bin\zip.dll
    0x05da0000 - 0x05daf000 E:\Apps\Java\j2sdk1.4.2\jre\bin\net.dll
    0x71c00000 - 0x71c17000 C:\WINDOWS\system32\WS2_32.dll
    0x71bf0000 - 0x71bf8000 C:\WINDOWS\system32\WS2HELP.dll
    0x71b20000 - 0x71b61000 C:\WINDOWS\System32\mswsock.dll
    0x76ed0000 - 0x76ef9000 C:\WINDOWS\system32\DNSAPI.dll
    0x76f70000 - 0x76f77000 C:\WINDOWS\System32\winrnr.dll
    0x76f10000 - 0x76f3e000 C:\WINDOWS\system32\WLDAP32.dll
    0x76f80000 - 0x76f88000 C:\WINDOWS\system32\rasadhlp.dll
    0x68000000 - 0x6802f000 C:\WINDOWS\system32\rsaenh.dll
    0x7c8d0000 - 0x7d0d4000 C:\WINDOWS\system32\SHELL32.dll
    0x77da0000 - 0x77df2000 C:\WINDOWS\system32\SHLWAPI.dll
    0x77420000 - 0x77523000 C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.3790.2778_x-ww_A8F04F11\comctl32.dll
    0x5f270000 - 0x5f2c9000 C:\WINDOWS\system32\hnetcfg.dll
    0x71ae0000 - 0x71ae8000 C:\WINDOWS\System32\wshtcpip.dll
    0x067b0000 - 0x067c1000 E:\Apps\webMethods6CEI\IntegrationServer\packages\ AssetCenter\code\libs\JAVAACUTIL.dll
    0x06eb0000 - 0x06ec9000 E:\Apps\webMethods6CEI\IntegrationServer\packages\ AssetCenter\code\libs\JAVAPO.dll
    0x06ed0000 - 0x07298000 E:\Apps\AssetCenter\bin\aamapi50.dll
    0x61c20000 - 0x61e76000 e:\oracle\product\10.2.0\bin\oraclient10.dll
    0x60870000 - 0x60956000 e:\oracle\product\10.2.0\bin\oracore10.dll
    0x60a80000 - 0x60b46000 e:\oracle\product\10.2.0\bin\oranls10.dll
    0x63690000 - 0x636a8000 e:\oracle\product\10.2.0\bin\oraunls10.dll
    0x7c340000 - 0x7c396000 C:\WINDOWS\system32\MSVCR71.dll
    0x60eb0000 - 0x60eb7000 e:\oracle\product\10.2.0\bin\orauts.dll
    0x77670000 - 0x777a4000 C:\WINDOWS\system32\ole32.dll
    0x636b0000 - 0x636b6000 e:\oracle\product\10.2.0\bin\oravsn10.dll
    0x60fa0000 - 0x61092000 e:\oracle\product\10.2.0\bin\oracommon10.dll
    0x073f0000 - 0x07a3d000 e:\oracle\product\10.2.0\bin\orageneric10.dll
    0x63430000 - 0x63457000 e:\oracle\product\10.2.0\bin\orasnls10.dll
    0x63750000 - 0x638bf000 e:\oracle\product\10.2.0\bin\oraxml10.dll
    0x60020000 - 0x60030000 C:\WINDOWS\system32\MSVCIRT.dll
    0x60960000 - 0x60a7e000 e:\oracle\product\10.2.0\bin\oran10.dll
    0x62740000 - 0x6277d000 e:\oracle\product\10.2.0\bin\oranl10.dll
    0x62790000 - 0x627a6000 e:\oracle\product\10.2.0\bin\oranldap10.dll
    0x627f0000 - 0x628fc000 e:\oracle\product\10.2.0\bin\orannzsbb10.dll
    0x62530000 - 0x625a3000 e:\oracle\product\10.2.0\bin\oraldapclnt10.dll
    0x62670000 - 0x6268b000 e:\oracle\product\10.2.0\bin\orancrypt10.dll
    0x71bb0000 - 0x71bb9000 C:\WINDOWS\system32\WSOCK32.dll
    0x76cf0000 - 0x76d0a000 C:\WINDOWS\system32\iphlpapi.dll
    0x77d00000 - 0x77d8c000 C:\WINDOWS\system32\OLEAUT32.dll
    0x62920000 - 0x6296d000 e:\oracle\product\10.2.0\bin\oranro10.dll
    0x626b0000 - 0x626b7000 e:\oracle\product\10.2.0\bin\oranhost10.dll
    0x62660000 - 0x62666000 e:\oracle\product\10.2.0\bin\orancds10.dll
    0x629c0000 - 0x629c8000 e:\oracle\product\10.2.0\bin\orantns10.dll
    0x60b50000 - 0x60ea8000 e:\oracle\product\10.2.0\bin\orapls10.dll
    0x07a40000 - 0x07a49000 e:\oracle\product\10.2.0\bin\oraslax10.dll
    0x63080000 - 0x63284000 e:\oracle\product\10.2.0\bin\oraplp10.dll
    0x61ed0000 - 0x61f56000 e:\oracle\product\10.2.0\bin\orahasgen10.dll
    0x62ab0000 - 0x62b1e000 e:\oracle\product\10.2.0\bin\oraocr10.dll
    0x62b20000 - 0x62b63000 e:\oracle\product\10.2.0\bin\oraocrb10.dll
    0x62980000 - 0x62990000 e:\oracle\product\10.2.0\bin\orantcp10.dll
    0x63520000 - 0x635ba000 e:\oracle\product\10.2.0\bin\orasql10.dll
    0x77b90000 - 0x77b98000 C:\WINDOWS\system32\version.dll
    0x07f00000 - 0x07f20000 E:\Apps\webMethods6CEI\IntegrationServer\packages\ AssetCenter\code\libs\JAVAPOACK.dll

    VM Arguments:
    jvm_args: -Xms256M -Xmx512M -Xrs -DWM_HOME=E:\Apps\webMethods6CEI\IntegrationServer\ ..
    java_command: E:\Apps\webMethods6CEI\IntegrationServer\bin\ini.c nf -pcp -acp E:\Apps\webMethods6CEI\Jars\AssetCenter.jar -ecp -debug 4 -log none
    Launcher Type: SUN_STANDARD

    Environment Variables:
    CLASSPATH=;"E:\Apps\Java\j2sdk1.4.2\jre\lib\rt.jar ;E:\Apps\Java\j2sdk1.4.2\jre\lib\i18n.jar";"E:\App s\webMethods6CEI\IntegrationServer\lib\proxy.jar";
    PATH=packages\WmWin32\code\libs;packages\AssetCent er\code\libs;C:\Program Files\Business Objects\Common\3.5\bin\;E:\Apps\Java\j2sdk1.4.2\bi n;E:\Apps\AssetCenter\bin;e:\oracle\product\10.2.0 \bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\Sys tem32\Wbem;D:\Program Files\Tools;d:\tivoli\tsm\baclient;D:\Program Files\IBM\Director\bin;D:\PROGRA~1\BMCSOF~1\common \globalc\bin\Windows-x86;D:\PROGRA~1\BMCSOF~1\Patrol3\bin;D:\PROGRA~1\B MCSOF~1\Patrol3\bin;d:\PROGRA~1\BMCSOF~1\Patrol3\b in;d:\PROGRA~1\BMCSOF~1\Patrol3\bin;D:\PROGRA~1\BM CSOF~1\Patrol3\bin;D:\Program Files\BMC Software\Patrol3\BEST1\7.3.00\bgs\bin;E:\Apps\webM ethods6CEI\IntegrationServer\..\common\bin;E:\Apps \webMethods6CEI\IntegrationServer\support\win32;E: \Apps\Java\j2sdk1.4.2\jre\bin\server;E:\Apps\webMe thods6CEI\IntegrationServer\lib;
    PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 6, GenuineIntel

    --------------- S Y S T E M ---------------

    OS: Windows Server 2003 family Build 3790 Service Pack 1

    CPU:total 2 family 6, cmov, cx8, fxsr, mmx, sse, sse2

    Memory: 4k page, physical 2097151k(2097151k free), swap 4194303k(4194303k free)

    vm_info: Java HotSpot(TM) Server VM (1.4.2_13-b06) for windows-x86, built on Oct 18 2006 09:54:05 by "java_re" with MS VC++ 6.0

    Please help!!!!

  6. #6
    georgemc is offline Senior Member
    Join Date
    Sep 2008
    Rep Power


    Upgrade your JVM

  7. #7
    DevzAbhi's Avatar
    DevzAbhi is offline Member
    Join Date
    Jul 2008
    Rep Power


    upgrade the jvm to 1.5.0_09

    is your machine hosting 64 bit os

  8. #8
    very9music is offline Member
    Join Date
    Nov 2008
    Rep Power


    Some DLL Files are corrupted. I think so.

  9. #9
    amit78g is offline Member
    Join Date
    Nov 2008
    Rep Power


    Try upgrading your RAM above 512Mb. Hopefully that should resolve your problem.

  10. #10
    benderr2001 is offline Member
    Join Date
    Jul 2009
    Rep Power

    Thumbs up For what it's worth

    Hello everyone,

    I encountered the exact same error in a Windows non-Eclipse type of environment. The problem was resolved by terminating the java process that persisted in memory. Also, the version appears to be irrelevant (in my case it was 1.6).


  11. #11
    othonielsan is offline Member
    Join Date
    Dec 2009
    Rep Power


    I Resolved this Issue.
    First Uninstalled all version of Java from your PC then download CCleaner and clean the Registry now Install a Downgrade Version Of Java, can be JVM 1.4 so you can tray again

  12. #12
    Join Date
    Jan 2011
    Rep Power


    I had also faced same problem, when i was trying to open my workspace via myEclipse 6.1.
    After enabling the following radio button in workspace i was done the problem.

    Windows > preferences >>Team>>SVN>> under svn interfaces >> SVNLIT (Pure Java ) this radio box should be enabled.

  13. #13
    robi is offline Member
    Join Date
    Mar 2011
    Rep Power


    Ive got the same problem while running a test application with the jpl.
    Ive done all the steps which are described on this homepage:
    Getting Started
    When i tried to start it, i got the mentioned exception/error.

    And all the things you have described in here changed nothing...

Similar Threads

  1. Exception_access_violation
    By naveen.panc in forum JavaServer Pages (JSP) and JSTL
    Replies: 3
    Last Post: 11-15-2008, 01:27 AM
  2. Replies: 2
    Last Post: 11-14-2008, 07:57 AM
    By abhiN in forum Eclipse
    Replies: 1
    Last Post: 11-14-2008, 07:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts