Results 1 to 2 of 2
  1. #1
    livnihai is offline Member
    Join Date
    Sep 2009
    Rep Power

    Default Error: Access restriction

    My program use javax.comm.*.

    The progam worked just fine with eclipse, and I had a problem to execute
    it wit a bat file (didn't solve that problem yet). I've changed classpath and copied comm.jar to many libraries, and suddenly the error below appear.

    I have this error

    "Access restriction: The type CommPortIdentifier is not accessible due to restriction on required library C:\Program Files\Java\jre6\lib\ext\comm.jar"

    When I look at that library comm.jar is there.

    thanks for any help

  2. #2
    vimalamrutiya is offline Member
    Join Date
    Nov 2009
    Rep Power


    You can probably try this -
    Go to Build path -> Configure Build path and follow the below steps.
    1) expand the comm.jar
    2) Select "Access rules" and click Edit Button
    3) Click Add button in the newly opened dialog.
    4) Select "Acceessible" and enter value "**"
    5) OK
    6) Clean build the project.

    Plese get back to me if solved.

Similar Threads

  1. Replies: 6
    Last Post: 02-10-2011, 10:55 AM
  2. [SOLVED] Access Denied error using FileInputStream
    By xcallmejudasx in forum New To Java
    Replies: 8
    Last Post: 05-21-2009, 04:13 AM
  3. Replies: 1
    Last Post: 03-24-2009, 01:52 PM
  4. Can we lift the images restriction?
    By Cyorxamp in forum Suggestions & Feedback
    Replies: 30
    Last Post: 07-01-2008, 08:32 AM
  5. Replies: 1
    Last Post: 08-07-2007, 07:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts