Results 1 to 1 of 1
  1. #1
    smoothrace is offline Member
    Join Date
    Jan 2015
    Posts
    1
    Rep Power
    0

    Default Maven throws errors pointing to settings.xml

    Hi I try run mvn and I get the following errors:


    C:\Users\496>mvn building -o
    [ERROR] Error executing Maven.
    [ERROR] 8 problems were encountered while building the effective settings
    [ERROR] 'servers.server[0].id' is missing @ C:\Users\496\.m2\settings.xml
    [ERROR] 'mirrors.mirror.id' for is missing @ C:\Users\496\.m2\settings.xml
    [ERROR] 'mirrors.mirror.url' for is missing @ C:\Users\49\.m2\settings.xml
    [ERROR] 'mirrors.mirror.mirrorOf' for is missing @ C:\Users\496\.m2\settings.xml
    [ERROR] 'profiles.profile[].repositories.repository.id' for is missing @ C:\Users\496\.m2\settings.xml
    [ERROR] 'profiles.profile[].repositories.repository.url' for is missing @ C:\Users\496\.m2\settings.xml
    [ERROR] 'profiles.profile[].pluginRepositories.pluginRepository.id' for is missing @ C:\Users\496\.m2\settings.xml
    [ERROR] 'profiles.profile[].pluginRepositories.pluginRepository.url' for is missing @ C:\Users\496\.m2\settings.xml


    can somebody help me

    cheers
    Last edited by smoothrace; 01-28-2015 at 07:43 AM.

Similar Threads

  1. Replies: 0
    Last Post: 12-30-2013, 07:01 AM
  2. Replies: 0
    Last Post: 12-17-2012, 01:32 PM
  3. pointing to 1st record in a file
    By swati.jyoti in forum New To Java
    Replies: 1
    Last Post: 04-25-2009, 08:38 AM
  4. Replies: 0
    Last Post: 04-20-2009, 06:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •