Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By pedroffbarbosa

Thread: Solve JVM Problem

  1. #1
    Join Date
    Aug 2011
    Rep Power

    Default Solve JVM Problem

    Hi everybody,
    I'm having an huge problem with JVM (I think), I had NetBeans 7.0.1 installed on my computer, then I uninstalled, and then I re-installed. But the problem is that now, every time I try to run NetBeans from the shortcut on Desktop, nothing happens, nothing at all, the OS starts to load something, like usual when you execute/run any program, but then, nothing happens or appears. But if I try to run NetBeans from the install folder, then it creates a log file, this is the log file content:

    Java Code:
    # A fatal error has been detected by the Java Runtime Environment: 
    #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00000000779a0895, pid=6056, tid=3660 
    # JRE version: 7.0-b147 
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (21.0-b17 mixed mode windows-amd64 compressed oops) 
    # Problematic frame: 
    # C  [ntdll.dll+0x50895] 
    # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows 
    # If you would like to submit a bug report, please visit: 
    ---------------  T H R E A D  --------------- 
    Current thread (0x0000000009820800):  JavaThread "main" [_thread_in_Java, id=3660, stack(0x000000000ab10000,0x000000000ad10000)] 
    siginfo: ExceptionCode=0xc0000005, reading address 0xffffffffffffffff 
    RAX=0x000000000ad0e7c8, RBX=0x0000000000000002, RCX=0x000000000ad0e898, RDX=0x000000000ad0e808 
    RSP=0x000000000ad0e7b8, RBP=0x000007feec35ef10, RSI=0x0000000000000020, RDI=0x0000000000000000 
    R8 =0x000000000ad05000, R9 =0x0000000000000003, R10=0x0000000000000000, R11=0x0000000000004ee8 
    R12=0x0000000000000000, R13=0x0000000000000050, R14=0x0000000000000003, R15=0x0000000009820800 
    RIP=0x00000000779a0895, EFLAGS=0x0000000000010202 
    Top of Stack: (sp=0x000000000ad0e7b8) 
    0x000000000ad0e7b8:   0000000000000202 000000007795b239 
    0x000000000ad0e7c8:   000007fffff8a000 00000000097eb4e0 
    0x000000000ad0e7d8:   0000000000000006 0000000000000000 
    0x000000000ad0e7e8:   0000000009820801 00000000089fce50 
    0x000000000ad0e7f8:   000000006a02ad48 00000000097eb4e0 
    0x000000000ad0e808:   000000000ad10000 000000000ad05000 
    0x000000000ad0e818:   00000000089fd188 000000000ad0ea01 
    0x000000000ad0e828:   0000000000000000 000000000ad0e9e0 
    0x000000000ad0e838:   00000000024c0080 0000000000000008 
    0x000000000ad0e848:   000000000982da10 000000000ad0f040 
    0x000000000ad0e858:   0000000002ef743a 0000000002ef73d0 
    0x000000000ad0e868:   0000000000000000 0000000000000000 
    0x000000000ad0e878:   000000000ad0f040 0000000100000188 
    0x000000000ad0e888:   000000000982da60 000000000ad0f0a0 
    0x000000000ad0e898:   0000000002ec6330 0000000002ec5350 
    0x000000000ad0e8a8:   0000000000000000 00000000fbc3bed8 
    Instructions: (pc=0x00000000779a0895) 
    0x00000000779a0875:   d0 00 00 00 4c 89 a1 d8 00 00 00 4c 89 a9 e0 00 
    0x00000000779a0885:   00 00 4c 89 b1 e8 00 00 00 4c 89 b9 f0 00 00 00 
    0x00000000779a0895:   0f ae 81 00 01 00 00 0f 29 81 a0 01 00 00 0f 29 
    0x00000000779a08a5:   89 b0 01 00 00 0f 29 91 c0 01 00 00 0f 29 99 d0 
    Register to memory mapping: 
    RAX=0x000000000ad0e7c8 is pointing into the stack for thread: 0x0000000009820800 
    RBX=0x0000000000000002 is an unknown value 
    RCX=0x000000000ad0e898 is pointing into the stack for thread: 0x0000000009820800 
    RDX=0x000000000ad0e808 is pointing into the stack for thread: 0x0000000009820800 
    RSP=0x000000000ad0e7b8 is pointing into the stack for thread: 0x0000000009820800 
    RBP=0x000007feec35ef10 is an unknown value 
    RSI=0x0000000000000020 is an unknown value 
    RDI=0x0000000000000000 is an unknown value 
    R8 =0x000000000ad05000 is pointing into the stack for thread: 0x0000000009820800 
    R9 =0x0000000000000003 is an unknown value 
    R10=0x0000000000000000 is an unknown value 
    R11=0x0000000000004ee8 is an unknown value 
    R12=0x0000000000000000 is an unknown value 
    R13=0x0000000000000050 is an unknown value 
    R14=0x0000000000000003 is an unknown value 
    R15=0x0000000009820800 is a thread 
    Stack: [0x000000000ab10000,0x000000000ad10000],  sp=0x000000000ad0e7b8,  free space=2041k 
    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code) 
    C  [ntdll.dll+0x50895]  RtlCaptureContext+0x85 
    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code) 
    v  blob 0x0000000002ef74ff 
    j  java.lang.String.equals(Ljava/lang/Object;)Z+8 
    j  org.openide.util.Lookup.getDefault()Lorg/openide/util/Lookup;+19 
    j  org.netbeans.core.startup.TopLogging$LookupDel.<init>()V+5 
    j  org.netbeans.core.startup.TopLogging.<init>()V+213 
    j  org.netbeans.core.startup.TopLogging.initialize(Z)V+67 
    j  org.netbeans.core.startup.TopLogging.initialize()V+1 
    j  org.netbeans.core.startup.CLIOptions.initialize()V+0 
    j  org.netbeans.core.startup.Main.start([Ljava/lang/String;)V+92 
    v  ~StubRoutines::call_stub 
    ---------------  P R O C E S S  --------------- 
    Java Threads: ( => current thread ) 
    =>0x0000000009820800 JavaThread "main" [_thread_in_Java, id=3660, stack(0x000000000ab10000,0x000000000ad10000)] 
      0x00000000097f4000 JavaThread "Inactive RequestProcessor thread [Was:Secure CLI Port/org.netbeans.CLIHandler$2]" daemon [_thread_blocked, id=6120, stack(0x000000000a910000,0x000000000ab10000)] 
      0x00000000097d4000 JavaThread "CLI Requests Server" daemon [_thread_in_native, id=3804, stack(0x000000000a610000,0x000000000a810000)] 
      0x0000000008be5800 JavaThread "Active Reference Queue Daemon" daemon [_thread_blocked, id=4004, stack(0x0000000009480000,0x0000000009680000)] 
      0x0000000008b4a800 JavaThread "Timer-0" daemon [_thread_blocked, id=4608, stack(0x00000000090d0000,0x00000000092d0000)] 
      0x0000000008892800 JavaThread "Service Thread" daemon [_thread_blocked, id=5056, stack(0x0000000008da0000,0x0000000008fa0000)] 
      0x0000000007027800 JavaThread "C2 CompilerThread1" daemon [_thread_blocked, id=5032, stack(0x0000000008790000,0x0000000008890000)] 
      0x0000000007022800 JavaThread "C2 CompilerThread0" daemon [_thread_blocked, id=3420, stack(0x0000000008610000,0x0000000008710000)] 
      0x000000000701f800 JavaThread "Attach Listener" daemon [_thread_blocked, id=3276, stack(0x00000000083e0000,0x00000000085e0000)] 
      0x000000000701a800 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=2308, stack(0x0000000008120000,0x0000000008320000)] 
      0x0000000006f3c800 JavaThread "Finalizer" daemon [_thread_blocked, id=5956, stack(0x0000000007e50000,0x0000000008050000)] 
      0x0000000006f30000 JavaThread "Reference Handler" daemon [_thread_blocked, id=6036, stack(0x0000000007a90000,0x0000000007c90000)] 
      0x000000000252c000 JavaThread "main" [_thread_blocked, id=6028, stack(0x0000000002cc0000,0x0000000002ec0000)] 
    Other Threads: 
      0x0000000006f21000 VMThread [stack: 0x0000000007890000,0x0000000007990000] [id=2208] 
      0x000000000889d800 WatcherThread [stack: 0x0000000007cb0000,0x0000000007db0000] [id=2484] 
    VM state:not at safepoint (normal execution) 
    VM Mutex/Monitor currently owned by a thread: None 
     PSYoungGen      total 9536K, used 4713K [0x00000000fbc00000, 0x00000000fc6a0000, 0x0000000100000000) 
      eden space 8192K, 57% used [0x00000000fbc00000,0x00000000fc09a468,0x00000000fc400000) 
      from space 1344K, 0% used [0x00000000fc550000,0x00000000fc550000,0x00000000fc6a0000) 
      to   space 1344K, 0% used [0x00000000fc400000,0x00000000fc400000,0x00000000fc550000) 
     PSOldGen        total 21888K, used 0K [0x00000000f3400000, 0x00000000f4960000, 0x00000000fbc00000) 
      object space 21888K, 0% used [0x00000000f3400000,0x00000000f3400000,0x00000000f4960000) 
     PSPermGen       total 32768K, used 5229K [0x00000000db400000, 0x00000000dd400000, 0x00000000f3400000) 
      object space 32768K, 15% used [0x00000000db400000,0x00000000db91b728,0x00000000dd400000) 
    Code Cache  [0x0000000002ec0000, 0x0000000003130000, 0x0000000005ec0000) 
     total_blobs=245 nmethods=19 adapters=178 free_code_cache=48712Kb largest_free_block=49858880 
    Dynamic libraries: 
    0x000000013f920000 - 0x000000013f953000    D:\Java\Java7\jre\bin\javaw.exe 
    0x0000000077950000 - 0x0000000077af9000    C:\Windows\SYSTEM32\ntdll.dll 
    0x0000000077580000 - 0x000000007769f000    C:\Windows\system32\kernel32.dll 
    0x000007fefdea0000 - 0x000007fefdf0c000    C:\Windows\system32\KERNELBASE.dll 
    0x000007feffae0000 - 0x000007feffbbb000    C:\Windows\system32\ADVAPI32.dll 
    0x000007feffa30000 - 0x000007feffacf000    C:\Windows\system32\msvcrt.dll 
    0x000007feff450000 - 0x000007feff46f000    C:\Windows\SYSTEM32\sechost.dll 
    0x000007feff470000 - 0x000007feff59d000    C:\Windows\system32\RPCRT4.dll 
    0x0000000077270000 - 0x000000007736a000    C:\Windows\system32\USER32.dll 
    0x000007feff6f0000 - 0x000007feff757000    C:\Windows\system32\GDI32.dll 
    0x000007feffad0000 - 0x000007feffade000    C:\Windows\system32\LPK.dll 
    0x000007fefef10000 - 0x000007fefefd9000    C:\Windows\system32\USP10.dll 
    0x000007fefbc90000 - 0x000007fefbe84000    C:\Windows\WinSxS\\COMCTL32.dll
    0x000007feffbe0000 - 0x000007feffc51000    C:\Windows\system32\SHLWAPI.dll 
    0x000007fefdc90000 - 0x000007fefdce7000    C:\Windows\system32\apphelp.dll 
    0x000007feecdc0000 - 0x000007feece1a000    C:\Windows\AppPatch\AppPatch64\AcLayers.DLL 
    0x000007fefc210000 - 0x000007fefc281000    C:\Windows\system32\WINSPOOL.DRV 
    0x000007fef6910000 - 0x000007fef6928000    C:\Windows\system32\MPR.dll 
    0x000007feec240000 - 0x000007feec6a7000    C:\Windows\AppPatch\AppPatch64\AcXtrnal.DLL 
    0x000007feecbe0000 - 0x000007feecc31000    C:\Windows\AppPatch\AppPatch64\AcGenral.DLL 
    0x000007fefdc50000 - 0x000007fefdc75000    C:\Windows\system32\SspiCli.dll 
    0x000007feff060000 - 0x000007feff263000    C:\Windows\system32\ole32.dll 
    0x000007fefe180000 - 0x000007fefef08000    C:\Windows\system32\SHELL32.dll 
    0x0000000070d40000 - 0x0000000070d43000    C:\Windows\system32\sfc.dll 
    0x000007fef6140000 - 0x000007fef6150000    C:\Windows\system32\sfc_os.DLL 
    0x000007fefcf70000 - 0x000007fefcf8e000    C:\Windows\system32\USERENV.dll 
    0x000007fefddb0000 - 0x000007fefddbf000    C:\Windows\system32\profapi.dll 
    0x000007fefb330000 - 0x000007fefb348000    C:\Windows\system32\dwmapi.dll 
    0x000007feff6b0000 - 0x000007feff6de000    C:\Windows\system32\IMM32.DLL 
    0x000007feff5a0000 - 0x000007feff6a9000    C:\Windows\system32\MSCTF.dll 
    0x000000006a560000 - 0x000000006a631000    D:\Java\Java7\jre\bin\msvcr100.dll 
    0x0000000069e90000 - 0x000000006a55e000    D:\Java\Java7\jre\bin\server\jvm.dll 
    0x000007fefad80000 - 0x000007fefad89000    C:\Windows\system32\WSOCK32.dll 
    0x000007feff860000 - 0x000007feff8ad000    C:\Windows\system32\WS2_32.dll 
    0x000007feff6e0000 - 0x000007feff6e8000    C:\Windows\system32\NSI.dll 
    0x000007fefc850000 - 0x000007fefc88b000    C:\Windows\system32\WINMM.dll 
    0x0000000077b20000 - 0x0000000077b27000    C:\Windows\system32\PSAPI.DLL 
    0x000000006fa60000 - 0x000000006fa6f000    D:\Java\Java7\jre\bin\verify.dll 
    0x0000000069e60000 - 0x0000000069e88000    D:\Java\Java7\jre\bin\java.dll 
    0x0000000069e40000 - 0x0000000069e55000    D:\Java\Java7\jre\bin\zip.dll 
    0x0000000069e20000 - 0x0000000069e39000    D:\Java\Java7\jre\bin\net.dll 
    0x000007fefd600000 - 0x000007fefd655000    C:\Windows\system32\mswsock.dll 
    0x000007fefd880000 - 0x000007fefd887000    C:\Windows\System32\wship6.dll 
    0x0000000069e00000 - 0x0000000069e11000    D:\Java\Java7\jre\bin\nio.dll 
    0x000007fefc690000 - 0x000007fefc6b7000    C:\Windows\system32\IPHLPAPI.DLL 
    0x000007fefc810000 - 0x000007fefc81b000    C:\Windows\system32\WINNSI.DLL 
    0x000007fefbac0000 - 0x000007fefbad8000    C:\Windows\system32\dhcpcsvc.DLL 
    0x000007fefbaa0000 - 0x000007fefbab1000    C:\Windows\system32\dhcpcsvc6.DLL 
    0x000007fefd660000 - 0x000007fefd677000    C:\Windows\system32\CRYPTSP.dll 
    0x000007fefd550000 - 0x000007fefd597000    C:\Windows\system32\rsaenh.dll 
    0x000007fefdc80000 - 0x000007fefdc8f000    C:\Windows\system32\CRYPTBASE.dll 
    0x000007fefc3a0000 - 0x000007fefc3b5000    C:\Windows\system32\NLAapi.dll 
    0x000007fefbfb0000 - 0x000007fefbfc5000    C:\Windows\system32\napinsp.dll 
    0x000007fefbf90000 - 0x000007fefbfa9000    C:\Windows\system32\pnrpnsp.dll 
    0x000007fefbf80000 - 0x000007fefbf90000    C:\Windows\system32\wshbth.dll 
    0x000007fefd3b0000 - 0x000007fefd40b000    C:\Windows\system32\DNSAPI.dll 
    0x000007fefbf70000 - 0x000007fefbf7b000    C:\Windows\System32\winrnr.dll 
    0x000007fef5380000 - 0x000007fef53af000    C:\Program Files\Common Files\Microsoft Shared\Windows Live\WLIDNSP.DLL 
    0x000007fefce50000 - 0x000007fefce57000    C:\Windows\System32\wshtcpip.dll 
    0x000007fef5370000 - 0x000007fef5378000    C:\Windows\system32\rasadhlp.dll 
    0x000007fefbb40000 - 0x000007fefbb93000    C:\Windows\System32\fwpuclnt.dll 
    VM Arguments: 
    jvm_args: -Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade -Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense -Xss2m -Xms32m -XX:PermSize=32m -Dapple.laf.useScreenMenuBar=true -Dsun.java2d.noddraw=true -Xmx204m -XX:MaxPermSize=384m -Djdk.home=D:\Java\Java7 -Dnetbeans.home=D:\Java\NetBeans 7\platform -Dnetbeans.user=C:\Users\Sammael\.netbeans\7.0 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=C:\Users\Sammael\.netbeans\7.0\var\log\heapdump.hprof -Dnetbeans.system_http_proxy=DIRECT -Dsun.awt.keepWorkingSetOnMinimize=true -Dnetbeans.dirs=D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\nb;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\ergonomics;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\ide;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\java;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\xml;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\apisupport;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\webcommon;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\websvccommon;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\enterprise;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\mobility;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\profiler;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\ruby;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\python;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\php;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\visualweb;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\soa;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\identity;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\uml;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\harness;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\cnd;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\dlight;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\groovy;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\javafx;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\javacard;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra;D:\Java\NetBeans 7.0.1\NetBeans 7.0.1\extra 
    java_command: org/netbeans/Main --branding nb 
    Launcher Type: SUN_STANDARD 
    Environment Variables: 
    PATH=C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Broadcom\Broadcom 802.11 Network Adapter;D:\Bluetooth_Software\;D:\Bluetooth_Software\syswow64;C:\Program Files\Intel\DMIX;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Program Files (x86)\Windows Live\Shared 
    PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 30 Stepping 5, GenuineIntel 
    ---------------  S Y S T E M  --------------- 
    OS: Windows 7 , 64 bit Build 7600 
    CPU:total 8 (4 cores per cpu, 2 threads per core) family 6 model 30 stepping 5, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, ht 
    Memory: 4k page, physical 6279684k(4374732k free), swap 18837204k(16481236k free) 
    vm_info: Java HotSpot(TM) 64-Bit Server VM (21.0-b17) for windows-amd64 JRE (1.7.0-b147), built on Jun 27 2011 02:19:45 by "java_re" with unknown MS VC++:1600 
    time: Sat Aug 27 17:47:08 2011 
    elapsed time: 0 seconds
    For what I understand the problem is related to JVM and that "ntdll.dll", but I have absolutely no idea, on how to solve this problem and why did this happen. I re-installed JDK, both, JDK 7 and JDK 6 (with the last update) then I tried with only one version installed, I tried both versions of JDK x86 and the x64, it stills the same, I re-installed NetBeans, JDK (again), GlassFish, Groovy... and nothing has changed, I solved some issues from reg with CCleaner, as I saw that the problem could be related with any bad registry, and guess what :D
    Didn't work.

    I'm really out of ideas to solve this, can anybody help me out?
    Last edited by pedroffbarbosa; 08-28-2011 at 12:41 AM.
    drakula941 likes this.

  2. #2
    Junky's Avatar
    Junky is offline Grand Poobah
    Join Date
    Jan 2011
    Rep Power


    This is a Java forum not a tech helpdesk.

  3. #3
    Join Date
    Aug 2011
    Rep Power


    I know that this is a forum, I learned to read at a long time ago. But, in that case you only come to the forum to chat, right??? You've never posted anything asking for help. You're my hero dude eheheheheh
    Maybe you're right, and maybe this isnt the best place to post this question/problem, but as a forum, there's a lot of people who can see my post and therefore, the possibility to be helped is real... So I think that you can understand, can't you?
    But yeah, you're the boss, what can I do ..... hihihihihihihihi Thanks for your help, in the same

  4. #4
    JosAH's Avatar
    JosAH is offline Moderator
    Join Date
    Sep 2008
    Voorschoten, the Netherlands
    Blog Entries
    Rep Power


    The JVM uses shared objects (dynamic link libraries) it can be sure of that they exist and run properly. The .dll files are present on your system but there's a bug one of them (hence the segmentation violation). You probably ran some suspicous software in the (near) past that affected your system. Those errors are nasty to pin down. That's Microsoft Windows: it's leaking like a basket and doesn't tell you what happened when you need it most. Maybe a fresh install of the entire OS can help? o.t.o.h. most people run that blasphemy of an OS with root privileges for their dayly 'tasks'. It's not Java's fault.

    kind regards,

    Build a wall around Donald Trump; I'll pay for it.

  5. #5
    Join Date
    Aug 2011
    Rep Power


    Yeah, I'm pretty sure that this is not Java's fault, it was working before I had that "fantastic" idea to uninstall it eheheh
    But I found the message.log file from netBeans in a different location from the file that I posted here and, it may seem strange, but there's one startup error there "java.lang.NoClassDefFoundError". So I believe that if I can solve that, maybe and maybe it will solve my problem.
    Your advise about the fresh install of the OS, well it was my first thought, since the problem was on that .dll ('cause you can't replace it without re-install the OS, as far as I know), but try to work a little around the problem didn't seemed to be a bad idea neither xD
    Thank you very much for your explanation.

    Best regards,

  6. #6
    Join Date
    Aug 2011
    Rep Power


    Done, I solved the problem adding the "" location (wich is inside the folder "java\lib" ), to the JAVA_HOME ENV VAR.
    Thanks for the tips.
    Best ragards,
    Last edited by pedroffbarbosa; 08-30-2011 at 05:26 PM.

  7. #7
    Michael Lauer is offline Member
    Join Date
    Nov 2011
    Rep Power

    Default Re: Solve JVM Problem

    I had the same issue, windows 7, java1.6 64bit, intellij 64 bit, the problem just arose while I was building a testing suite. This was after I had been using this configuration for 6 months and the only recent change was installing Selenium. I changed the java compiler in intellij from javac finally to the in process one that requires 1.6+, rebuilt my project, and the problem went away.

  8. #8
    Join Date
    Aug 2011
    Rep Power

    Default Re: Solve JVM Problem

    Man! Where were you 3 months ago, Michael Lauer ? Thank you, but as I told, and I dont know very well how, I manage to solve the problem, I know I had to do something more to solve it, more than I said, but I completely forgot what I did, only thing I'm sure is that it did not involve anything like that.
    It's working everything fine now, but thank you very much for the reply.
    kind regards

  9. #9
    alzemanuel is offline Member
    Join Date
    Nov 2011
    Rep Power

    Default Re: Solve JVM Problem

    Quote Originally Posted by pedroffbarbosa View Post
    Done, I solved the problem adding the "" location (wich is inside the folder "java\lib" ), to the JAVA_HOME ENV VAR.
    Thanks for the tips.
    Best ragards,

    Can you be more specific here, I tried what you did, still not fixed?, may be I am missing some thing.

Similar Threads

  1. Need help to solve my problem
    By Copro in forum New To Java
    Replies: 4
    Last Post: 08-21-2009, 05:26 AM
  2. Could someone help me to solve this problem...
    By Vinny in forum Java Software
    Replies: 1
    Last Post: 07-08-2009, 07:59 PM
  3. Help me to solve problem
    By mansoorhacker in forum Forum Guides
    Replies: 8
    Last Post: 01-24-2009, 07:29 PM
  4. Solve my Problem
    By kyo in forum New To Java
    Replies: 1
    Last Post: 12-16-2008, 03:22 PM
  5. Help me to solve problem
    By mansoorhacker in forum New To Java
    Replies: 3
    Last Post: 11-13-2008, 09:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts