I'm trying to load unix library with function System.loadLibrary() and i get an error UnsatisfiedLinkError. Path to directory with library is in LD_LIBRARY_PATH, so everything should be fine. I've tried to specify library path in comand line with switch Djava.library.path=. and nothing. I also write simple program (source code is below) which shows that library is where it should be, but I still get an error.

Java Code:
import java.lang.*;
import java.io.File;

class Start{
     private native void print();
		private static String file= "libstart";

     public static void main(String[] args) {
			}catch(UnsatisfiedLinkError err){
				String paths= System.getProperty("java.library.path");				
				System.out.print("In directory :\n" + paths + "\n " + file + ".so" + "\n was not found");
				String[] tab= paths.split(":");
				for(int i=0; i<tab.length; i++){
					File f= new File(tab[i]+ file + ".so");
						System.out.print("\nFile is in directory: " + f.getPath()+ "\n");
When I run this program the output is:
Java Code:
$ java -Djava.library.path=/home/xxxx/Desktop/ -classpath . Start
In directory :
 file libstart.so was not found
File is in directory: /home/xxxx/Desktop/libstart.so
This confirm that library is in the right place.

Any ideas what's wrong?