My situation is as follows:
I have a library X.dll made in C# (by a third party) that exports a class X.
I need to instantiate that class and excecute its methods from java.
For that I'm trying DotNetFromJava.
The first step sopose me to excecute the following line:

java -cp .\dotnetfromjava.jar gr.dotnetfromjava.codegen.Net2JCodeGen fullPathToTheDLL

That throws the following exception:

Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\<directorio al proyecto>\gr.DotNetFromJava.cpp.dll: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1751)
at java.lang.ClassLoader.loadLibrary( :1676)
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at gr.dotnetfromjava.base.NETManager.<clinit>(NETMana
at gr.dotnetfromjava.codegen.Net2JCodeGen.main(Net2JC

Then I got into the code and I found the exception ocurrs in the line:


It means it finds the dll but gets an error at opening it.
I searched in the foros for a solutin to this problem and i found the following explanation that seems to have solved the problem to the person who originated the thread of conversation.
http : //

I have Visual C# Express 2008 installed but it's not exactly my situation since it wasn't me how made the dll that doesn't work (gr.DotNetFromJava.cpp.dll) on some one else machine (the client machine). My situation is that I'm the client machine and the dll doesn't work on my machine. So I don't know if showld be following these instructions.
Any way, I searched the files msvcr80.dll, msvcp80.dll, msvcm80.dll in my machine and I found 3 diferent versions:
x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727. 42_x-ww_0de06acd
x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727. 762_x-ww_6b128700
x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727. 3053_x-ww_b80fa8ca

I tried to do what is told there with the 3 versions and none worked.

Could it be I'm trying the wrong version of msvcr80.dll, msvcp80.dll, msvcm80.dll ?
Any ideas how to proceed ?
Thanks a lot