Results 1 to 6 of 6
  1. #1
    pele's Avatar
    pele is offline Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    0

    Default Displaying text in a tabel

    Hi,

    I have a SWT table in which i try to add data, the data entry works fine . But when i have some data like (������) then it displays only Boxes. Can somebody tell me why this happens so ?

    Thanks
    pele

  2. #2
    Eranga's Avatar
    Eranga is offline Moderator
    Join Date
    Jul 2007
    Location
    Colombo, Sri Lanka
    Posts
    11,371
    Blog Entries
    1
    Rep Power
    20

  3. #3
    pele's Avatar
    pele is offline Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    0

    Default

    Basically its an entry on the the directory server, and its type is shown as OctetString. There are also chinese and japanese characters on the server, but they can be displayed properly in the table. Only these characters are being shown as squares.

  4. #4
    gogoc is offline Member
    Join Date
    May 2008
    Posts
    21
    Rep Power
    0

    Default

    so it is just a string
    it uses the system support for the languages so it is likely that ur system dosent support these languages

  5. #5
    Eranga's Avatar
    Eranga is offline Moderator
    Join Date
    Jul 2007
    Location
    Colombo, Sri Lanka
    Posts
    11,371
    Blog Entries
    1
    Rep Power
    20

    Default

    That's why I'm asking. You don't have see displaying those text, because it's not support your system. I think it's better to move with UNICODE.

  6. #6
    pele's Avatar
    pele is offline Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    0

    Default

    Can u pls help me enable the support for such characters on my system ??
    This seems to be a bit surprising as the chinese/japanese characters are displayed perfectly...

    One more thing, when i try to print those characters in a file they are printed properly, but if i try to display them in a text box or table (through code) then it displays as boxes. But if iu manually try to copy those charcters and paste them in a text box or table cell (Ctrl+C; Ctrl+V) the it displays them perfectly, it doesnt display boxes in this senario.So this is a bit strange, if the system didnt support such characters then i guess even copy paste would'nt have helped.

    Pls help ...

Similar Threads

  1. Replies: 0
    Last Post: 05-26-2008, 05:26 PM
  2. displaying string
    By jamborta in forum AWT / Swing
    Replies: 6
    Last Post: 01-23-2008, 08:15 PM
  3. Displaying data into text area
    By abhiN in forum New To Java
    Replies: 1
    Last Post: 01-22-2008, 11:30 AM
  4. Replies: 5
    Last Post: 01-17-2008, 10:01 PM
  5. Displaying text box on MIDlet form
    By Java Tip in forum Java Tip
    Replies: 0
    Last Post: 11-22-2007, 11:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •