Results 1 to 3 of 3
  1. #1
    mfc1006 is offline Member
    Join Date
    May 2014
    Posts
    4
    Rep Power
    0

    Default Spring Roo setup

    Hi everyone, I am new here and I am also a beginner in terms of Java programming. You may says that I am the dumbest, frustrated person who eagers to learn java by heart. I don't knwo where to post this question since I still don't have the capability to open or create a new thread here so I am posting my answer here. I hope it is ok to the thread started to post my questions here. By the way, I can't figure out how to solve my problem regarding installation of Spring Roo. The error are as follows:

    C:\>roo
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: com.github.antlrjavaparser.antlr-java-parser:1.0.14
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.commons.codec:1.8.0
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.commons.io:2.4.0
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.commons.lang3:3.1.0
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.fusesource.jansi:1.6.0
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: net.sourceforge.jline:1.0.0.S2-B
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.felix.bundlerepository:1.6.6
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.felix.ipojo:1.8.0
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.felix.log:1.0.1
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.felix.scr:1.6.0
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.apache.felix.shell:1.4.2
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.backup:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.configurable:1.2.5.R ELEA
    SE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.creator:1.2.5.RELEAS E
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.dbre:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.dod:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.email:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.equals:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.finder:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.gwt:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.javabean:1.2.5.RELEA SE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.jdbc:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.jms:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.jpa:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.jsf:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.json:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.layers.repository.jp a:1.
    2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.layers.repository.mo ngo:
    1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.layers.service:1.2.5 .REL
    EASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.logging:1.2.5.RELEAS E
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.oscommands:1.2.5.REL EASE

    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.plural:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.property.editor:1.2. 5.RE
    LEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.propfiles:1.2.5.RELE ASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.roobot.client:1.2.5. RELE
    ASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.security:1.2.5.RELEA SE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.serializable:1.2.5.R ELEA
    SE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.solr:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.tailor:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.test:1.2.5.RELEASE
    Auto-deploy install: org.osgi.framework.BundleException: Bundle symbolic name an
    d version are not unique: org.springframework.roo.addon.tostring:1.2.5.RELEA SE


    continuation of the error:

    [68.0] package; (package=javax.xml.namespace)]]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.file.undo [58] Error starting file:/D:/Spr
    ing%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.file.undo-1.2.
    5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bund
    le org.springframework.roo.file.undo [58]: Unable to resolve 58.0: missing requi
    rement [58.0] package; (&(package=org.springframework.roo.support.logging )(versi
    on>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 68.0: missing requi
    rement [68.0] package; (package=javax.xml.namespace)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.file.undo [58]: Unable to resolve 58.0: missing requirement [58.0] p
    ackage; (&(package=org.springframework.roo.support.logging )(version>=1.2.0)(!(ve
    rsion>=2.0.0))) [caused by: Unable to resolve 68.0: missing requirement [68.0] p
    ackage; (package=javax.xml.namespace)]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.model [60] Error starting file:/D:/Spring%
    20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.model-1.2.5.RELEAS
    E.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.s
    pringframework.roo.model [60]: Unable to resolve 60.0: missing requirement [60.0
    ] package; (package=javax.annotation))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.model [60]: Unable to resolve 60.0: missing requirement [60.0] packa
    ge; (package=javax.annotation)
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.process.manager [61] Error starting file:/
    D:/Spring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.process.
    manager-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constr
    aint in bundle org.springframework.roo.process.manager [61]: Unable to resolve 6
    1.0: missing requirement [61.0] package; (&(package=org.springframework.roo.file
    .monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 55.0
    : missing requirement [55.0] package; (&(package=org.springframework.roo.support
    .util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 68.0: m
    issing requirement [68.0] package; (package=javax.xml.namespace)]])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.process.manager [61]: Unable to resolve 61.0: missing requirement [6
    1.0] package; (&(package=org.springframework.roo.file.monitor)(v ersion>=1.2.0)(!
    (version>=2.0.0))) [caused by: Unable to resolve 55.0: missing requirement [55.0
    ] package; (&(package=org.springframework.roo.support.util)(v ersion>=1.2.0)(!(ve
    rsion>=2.0.0))) [caused by: Unable to resolve 68.0: missing requirement [68.0] p
    ackage; (package=javax.xml.namespace)]]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.project [62] Error starting file:/D:/Sprin
    g%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.project-1.2.5.RE
    LEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle o
    rg.springframework.roo.project [62]: Unable to resolve 62.0: missing requirement
    [62.0] package; (&(package=org.springframework.roo.file.monitor)(v ersion>=1.2.0
    )(!(version>=2.0.0))) [caused by: Unable to resolve 55.0: missing requirement [5
    5.0] package; (&(package=org.springframework.roo.support.util)(v ersion>=1.2.0)(!
    (version>=2.0.0))) [caused by: Unable to resolve 68.0: missing requirement [68.0
    ] package; (package=javax.xml.namespace)]])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.project [62]: Unable to resolve 62.0: missing requirement [62.0] pac
    kage; (&(package=org.springframework.roo.file.monitor)(v ersion>=1.2.0)(!(version
    >=2.0.0))) [caused by: Unable to resolve 55.0: missing requirement [55.0] packag
    e; (&(package=org.springframework.roo.support.util)(v ersion>=1.2.0)(!(version>=2
    .0.0))) [caused by: Unable to resolve 68.0: missing requirement [68.0] package;
    (package=javax.xml.namespace)]]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.shell [63] Error starting file:/D:/Spring%
    20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.shell-1.2.5.RELEAS
    E.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.s
    pringframework.roo.shell [63]: Unable to resolve 63.0: missing requirement [63.0
    ] package; (package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.shell [63]: Unable to resolve 63.0: missing requirement [63.0] packa
    ge; (package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.shell.jline [64] Error starting file:/D:/S
    pring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.shell.jline-
    1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in
    bundle org.springframework.roo.shell.jline [64]: Unable to resolve 64.0: missing
    requirement [64.0] package; (&(package=org.springframework.roo.shell)(version> =
    1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requireme
    nt [63.0] package; (package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.shell.jline [64]: Unable to resolve 64.0: missing requirement [64.0]
    package; (&(package=org.springframework.roo.shell)(version> =1.2.0)(!(version>=2
    .0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] package;
    (package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.shell.jline.osgi [65] Error starting file:
    /D:/Spring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.shell.j
    line.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved cons
    traint in bundle org.springframework.roo.shell.jline.osgi [65]: Unable to resolv
    e 65.0: missing requirement [65.0] package; (&(package=org.springframework.roo.s
    hell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: mi
    ssing requirement [63.0] package; (package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.shell.jline.osgi [65]: Unable to resolve 65.0: missing requirement [
    65.0] package; (&(package=org.springframework.roo.shell)(version> =1.2.0)(!(versi
    on>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] pack
    age; (package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.shell.osgi [66] Error starting file:/D:/Sp
    ring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.shell.osgi-1.
    2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bu
    ndle org.springframework.roo.shell.osgi [66]: Unable to resolve 66.0: missing re
    quirement [66.0] package; (&(package=org.springframework.roo.shell)(version> =1.2
    .0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement
    [63.0] package; (package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.shell.osgi [66]: Unable to resolve 66.0: missing requirement [66.0]
    package; (&(package=org.springframework.roo.shell)(version> =1.2.0)(!(version>=2.
    0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] package; (
    package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.startlevel [67] Error starting file:/D:/Sp
    ring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.startlevel-1.
    2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bu
    ndle org.springframework.roo.startlevel [67]: Unable to resolve 67.0: missing re
    quirement [67.0] package; (package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.startlevel [67]: Unable to resolve 67.0: missing requirement [67.0]
    package; (package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.support [68] Error starting file:/D:/Sprin
    g%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.support-1.2.5.RE
    LEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle o
    rg.springframework.roo.support [68]: Unable to resolve 68.0: missing requirement
    [68.0] package; (package=javax.xml.namespace))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.support [68]: Unable to resolve 68.0: missing requirement [68.0] pac
    kage; (package=javax.xml.namespace)
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.support.osgi [69] Error starting file:/D:/
    Spring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.support.osg
    i-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint i
    n bundle org.springframework.roo.support.osgi [69]: Unable to resolve 69.0: miss
    ing requirement [69.0] package; (&(package=org.springframework.roo.support.ant)(
    version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 68.0: missing
    requirement [68.0] package; (package=javax.xml.namespace)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.support.osgi [69]: Unable to resolve 69.0: missing requirement [69.0
    ] package; (&(package=org.springframework.roo.support.ant)(ve rsion>=1.2.0)(!(ver
    sion>=2.0.0))) [caused by: Unable to resolve 68.0: missing requirement [68.0] pa
    ckage; (package=javax.xml.namespace)]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.uaa [70] Error starting file:/D:/Spring%20
    Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.uaa-1.2.5.RELEASE.ja
    r (org.osgi.framework.BundleException: Unresolved constraint in bundle org.sprin
    gframework.roo.uaa [70]: Unable to resolve 70.0: missing requirement [70.0] pack
    age; (&(package=org.springframework.roo.shell)(version> =1.2.0)(!(version>=2.0.0)
    )) [caused by: Unable to resolve 63.0: missing requirement [63.0] package; (pack
    age=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.uaa [70]: Unable to resolve 70.0: missing requirement [70.0] package
    ; (&(package=org.springframework.roo.shell)(version> =1.2.0)(!(version>=2.0.0)))
    [caused by: Unable to resolve 63.0: missing requirement [63.0] package; (package
    =javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.url.stream.jdk [72] Error starting file:/D
    :/Spring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.url.strea
    m.jdk-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constrai
    nt in bundle org.springframework.roo.url.stream.jdk [72]: Unable to resolve 72.0
    : missing requirement [72.0] package; (&(package=org.springframework.roo.shell)(
    version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing
    requirement [63.0] package; (package=javax.xml.parsers)])
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.url.stream.jdk [72]: Unable to resolve 72.0: missing requirement [72
    .0] package; (&(package=org.springframework.roo.shell)(version> =1.2.0)(!(version
    >=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] packag
    e; (package=javax.xml.parsers)]
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.wrapping.antlr4-runtime [73] Error startin
    g file:/D:/Spring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.
    wrapping.antlr4-runtime-4.0.0002.jar (org.osgi.framework.BundleException: Unreso
    lved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [73]:
    Unable to resolve 73.0: missing requirement [73.0] package; (package=javax.image
    io))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.wrapping.antlr4-runtime [73]: Unable to resolve 73.0: missing requir
    ement [73.0] package; (package=javax.imageio)
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.roo.wrapping.bcprov-jdk15 [75] Error starting
    file:/D:/Spring%20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.roo.wr
    apping.bcprov-jdk15-1.45.0.0010.jar (org.osgi.framework.BundleException: Unresol
    ved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [75]: Una
    ble to resolve 75.0: missing requirement [75.0] package; (package=javax.crypto))

    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.roo.wrapping.bcprov-jdk15 [75]: Unable to resolve 75.0: missing requirem
    ent [75.0] package; (package=javax.crypto)
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)
    ERROR: Bundle org.springframework.uaa.client [80] Error starting file:/D:/Spring
    %20Roo/spring-roo-1.2.5.RELEASE/bundle/org.springframework.uaa.client-1.0.2.RELE
    ASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org
    .springframework.uaa.client [80]: Unable to resolve 80.0: missing requirement [8
    0.0] package; (package=javax.xml.parsers))
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr
    amework.uaa.client [80]: Unable to resolve 80.0: missing requirement [80.0] pack
    age; (package=javax.xml.parsers)
    at org.apache.felix.framework.Felix.resolveBundle(Fel ix.java:3564)
    at org.apache.felix.framework.Felix.startBundle(Felix .java:1797)
    at org.apache.felix.framework.Felix.setActiveStartLev el(Felix.java:1192)

    at org.apache.felix.framework.StartLevelImpl.run(Star tLevelImpl.java:266
    )
    at java.lang.Thread.run(Unknown Source)


    ---

    I already installed maven and it says apache-maven-3.2.1

    So don't know the problem and how to install or setup Spring Roo. Please help me! I am so frustrated but so eager to learn Java...

  2. #2
    Tolls is offline Moderator
    Join Date
    Apr 2009
    Posts
    12,091
    Rep Power
    20

    Default Re: Spring Roo setup

    You can start a thread.
    There's a big button at the top of each sub forum called "Post New Thread".
    Please do not ask for code as refusal often offends.

    ** This space for rent **

  3. #3
    mfc1006 is offline Member
    Join Date
    May 2014
    Posts
    4
    Rep Power
    0

Similar Threads

  1. Printing Setup
    By gbonecapone in forum New To Java
    Replies: 20
    Last Post: 07-12-2013, 04:33 PM
  2. Setup creator...
    By SagarMohril in forum New To Java
    Replies: 0
    Last Post: 01-07-2011, 01:11 PM
  3. Replies: 1
    Last Post: 12-27-2010, 05:21 PM
  4. please help me to create setup
    By javastuden in forum AWT / Swing
    Replies: 4
    Last Post: 11-10-2009, 05:58 AM
  5. Setup
    By Mir in forum New To Java
    Replies: 9
    Last Post: 06-27-2008, 11:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •