Results 1 to 7 of 7
  1. #1
    ken4ward is offline Member
    Join Date
    Aug 2013
    Posts
    3
    Rep Power
    0

    Default Web application not starting

    Please, I really need a help on this. I followed a tutorial online Spring 3 and hibernate integration tutorial with example | How to do in JAVA, and ever since I have been trying to deploy the application it keeps giving errors, what ami doing wrong?

    Java Code:
    Aug 14, 2013 2:46:14 PM org.apache.catalina.core.AprLifecycleListener init
    INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.7.0_17\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Users\Ken4ward\Desktop\Latest Cyclos\CloudBees\cloudbees-sdk-1.5.0;C:\Program Files\Java\jdk1.7.0_17\bin;C:\apache-maven-3.0.5\bin;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Ruby200-x64\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files (x86)\Git\cmd;C:\Ruby200-x64\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;.
    Aug 14, 2013 2:46:16 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
    WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:Spring3HibernateIntegration' did not find a matching property.
    Aug 14, 2013 2:46:18 PM org.apache.coyote.AbstractProtocol init
    INFO: Initializing ProtocolHandler ["http-bio-8585"]
    Aug 14, 2013 2:46:19 PM org.apache.coyote.AbstractProtocol init
    INFO: Initializing ProtocolHandler ["ajp-bio-8099"]
    Aug 14, 2013 2:46:19 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 4910 ms
    Aug 14, 2013 2:46:19 PM org.apache.catalina.core.StandardService startInternal
    INFO: Starting service Catalina
    Aug 14, 2013 2:46:19 PM org.apache.catalina.core.StandardEngine startInternal
    INFO: Starting Servlet Engine: Apache Tomcat/7.0.30
    Aug 14, 2013 2:46:20 PM org.apache.catalina.util.SessionIdGenerator createSecureRandom
    INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [280] milliseconds.
    Aug 14, 2013 2:46:27 PM org.apache.catalina.core.ApplicationContext log
    INFO: No Spring WebApplicationInitializer types detected on classpath
    Aug 14, 2013 2:46:27 PM org.apache.catalina.core.ApplicationContext log
    INFO: Initializing Spring root WebApplicationContext
    log4j:WARN No appenders could be found for logger (org.springframework.web.context.ContextLoader).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    Aug 14, 2013 2:46:28 PM org.apache.catalina.core.StandardContext listenerStart
    SEVERE: Exception sending context initialized event to listener instance of class org.springframework.web.context.ContextLoaderListener
    java.lang.NoClassDefFoundError: org/springframework/expression/PropertyAccessor
    	at org.springframework.context.support.AbstractApplicationContext.prepareBeanFactory(AbstractApplicationContext.java:553)
    	at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:454)
    	at org.springframework.web.context.ContextLoader.configureAndRefreshWebApplicationContext(ContextLoader.java:389)
    	at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:294)
    	at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:112)
    	at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4791)
    	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5285)
    	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559)
    	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549)
    	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
    	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
    	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    	at java.lang.Thread.run(Thread.java:722)
    Caused by: java.lang.ClassNotFoundException: org.springframework.expression.PropertyAccessor
    	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1714)
    	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1559)
    	... 15 more
    
    Aug 14, 2013 2:46:28 PM org.apache.catalina.core.StandardContext startInternal
    SEVERE: Error listenerStart
    Aug 14, 2013 2:46:28 PM org.apache.catalina.core.StandardContext startInternal
    SEVERE: Context [/Spring3HibernateIntegration] startup failed due to previous errors
    Aug 14, 2013 2:46:28 PM org.apache.catalina.core.ApplicationContext log
    INFO: Closing Spring root WebApplicationContext
    Aug 14, 2013 2:46:28 PM org.apache.coyote.AbstractProtocol start
    INFO: Starting ProtocolHandler ["http-bio-8585"]
    Aug 14, 2013 2:46:28 PM org.apache.coyote.AbstractProtocol start
    INFO: Starting ProtocolHandler ["ajp-bio-8099"]
    Aug 14, 2013 2:46:28 PM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 9763 ms

  2. #2
    gimbal2 is offline Just a guy
    Join Date
    Jun 2013
    Location
    Netherlands
    Posts
    4,030
    Rep Power
    6

    Default Re: Web application not starting

    Seems like you're missing a jar on the classpath or the application deployment is not working properly, since you're missing the jar which contains this class: "org.springframework.expression.PropertyAccess or" (a google refers to the "spring expressions jar"). Since the tutorial generates all that stuff for you through a maven archetype, I guess the tutorial is not going to work for you.
    "Syntactic sugar causes cancer of the semicolon." -- Alan Perlis

  3. #3
    ken4ward is offline Member
    Join Date
    Aug 2013
    Posts
    3
    Rep Power
    0

    Default Re: Web application not starting

    Quote Originally Posted by gimbal2 View Post
    Seems like you're missing a jar on the classpath or the application deployment is not working properly, since you're missing the jar which contains this class: "org.springframework.expression.PropertyAccess or" (a google refers to the "spring expressions jar"). Since the tutorial generates all that stuff for you through a maven archetype, I guess the tutorial is not going to work for you.
    I am not using maven, just a web application. I couldn't cope with the maven configuration problems. It's always been an headache whenever I try using it. As pertaining to the .jar file, I have spring-expression-3.22.jar in the lib of the project, that is why I am confused why it's not reading it? Any further help will be highly appreciated. Thanks.

  4. #4
    gimbal2 is offline Just a guy
    Join Date
    Jun 2013
    Location
    Netherlands
    Posts
    4,030
    Rep Power
    6

    Default Re: Web application not starting

    So you're NOT actually following that tutorial, you're just doing your own things. Right then...

    - what do you mean by "in the lib of the project"? What did you do -specifically- to add the jars?
    - Assuming you did not do something weird - when you open up this jar (you can expand it in the Eclipse project dependencies), is the mentioned class actually in there?
    - What is deployed to the server? Is the jar actually there? To which directory is it deployed?

    BTW: "It's always been an headache whenever I try using it" - you never did buy a Maven book to properly understand how it works, right? Its a complex tool that solves complex problems, you need to know your stuff before it can properly help you.
    "Syntactic sugar causes cancer of the semicolon." -- Alan Perlis

  5. #5
    ken4ward is offline Member
    Join Date
    Aug 2013
    Posts
    3
    Rep Power
    0

    Default Re: Web application not starting

    Thanks. I added the .jar file into the lib folder thus WEB-INF/lib by picking each from a bundle of all the frameworks used like spring-3.2.2, hibernate-4.1, etc. Preferably a recommendation of a good tutorial from an efficient user of Maven like you will be appreciated. The jars are there. What I did is that after I'd finished with the project I exported it as a war file into Tomcat webapp directory, ran the server and try to access it through the browser thus: localhost:8585/Spring3HibernateIntegration/index.jsp and it gives 404 error. What's the next step? Thanks.

  6. #6
    gimbal2 is offline Just a guy
    Join Date
    Jun 2013
    Location
    Netherlands
    Posts
    4,030
    Rep Power
    6

    Default Re: Web application not starting

    Research, study, learn, experiment - read. I am not going to invest time into someone that tries to get by just trying stuff and hoping for the best to be honest.
    "Syntactic sugar causes cancer of the semicolon." -- Alan Perlis

  7. #7
    anjaiahspr is offline Member
    Join Date
    Oct 2013
    Posts
    1
    Rep Power
    0

    Default Re: Web application not starting

    missing a jars and in web.xml file you need configure <context>ContextLoaderListner releated spring class

Similar Threads

  1. Starting out
    By Coltraine12 in forum New To Java
    Replies: 2
    Last Post: 09-24-2012, 04:03 PM
  2. IE7 crashes on starting java web application.
    By gosia.gabriel in forum Advanced Java
    Replies: 1
    Last Post: 01-19-2009, 02:29 PM
  3. starting a Swing application from an applet
    By FakeRabbit in forum Java Applets
    Replies: 9
    Last Post: 09-21-2008, 07:00 PM
  4. Application starting initially
    By rameshraj in forum Advanced Java
    Replies: 14
    Last Post: 04-27-2008, 07:48 PM
  5. just starting
    By specbailey in forum New To Java
    Replies: 23
    Last Post: 08-13-2007, 11:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •