Page 1 of 2 12 LastLast
Results 1 to 20 of 39
Like Tree1Likes

Thread: can't override a methode, it still ask for level 1.5 or greater

  1. #1
    joshhuar is offline Member
    Join Date
    Apr 2014
    Posts
    3
    Rep Power
    0

    Question can't override a methode, it still ask for level 1.5 or greater

    Hi this Josh,

    I'm using "standard-kepler-SR2-win32-x86_64" and have installed "jdk-8u5-windows-x64".
    But eventhough I can't override a methode like that "@override", it still says me:"annotations are only available, if source lever is 1.5 or greater".
    Fine, therefore I installad "jdk-8u5-windows-x64", its the higest one on that oracle side, what else is needed?

    thanks Josh

  2. #2
    jim829 is online now Senior Member
    Join Date
    Jan 2013
    Location
    Northern Virginia, United States
    Posts
    3,615
    Rep Power
    5

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    You may need to check that your Java compliance level is set correctly. Window -> preferences -> java -> compiler. This should also match your current JRE.

    Regards,
    Jim
    The Java™ Tutorial | SSCCE | Java Naming Conventions
    Poor planning our your part does not constitute an emergency on my part.

  3. #3
    joshhuar is offline Member
    Join Date
    Apr 2014
    Posts
    3
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    sounds good, but sorry I have to ask , where is that exactly, where I have to look

  4. #4
    Norm's Avatar
    Norm is online now Moderator
    Join Date
    Jun 2008
    Location
    SW Missouri
    Posts
    17,421
    Rep Power
    25

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    Is this an IDE problem?
    If you don't understand my response, don't ignore it, ask a question.

  5. #5
    joshhuar is offline Member
    Join Date
    Apr 2014
    Posts
    3
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    Its just I dont know where shall I look for that "Window -> preferences -> java -> "

  6. #6
    Norm's Avatar
    Norm is online now Moderator
    Join Date
    Jun 2008
    Location
    SW Missouri
    Posts
    17,421
    Rep Power
    25

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    How are you compiling? What program are you executing and how do you execute it?
    If you don't understand my response, don't ignore it, ask a question.

  7. #7
    jim829 is online now Senior Member
    Join Date
    Jan 2013
    Location
    Northern Virginia, United States
    Posts
    3,615
    Rep Power
    5

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    He's says he's using standard Kepler. It could be something else but Kepler is also a version of Eclipse.

    Regards,
    Jim
    The Java™ Tutorial | SSCCE | Java Naming Conventions
    Poor planning our your part does not constitute an emergency on my part.

  8. #8
    jim829 is online now Senior Member
    Join Date
    Jan 2013
    Location
    Northern Virginia, United States
    Posts
    3,615
    Rep Power
    5

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    I made an assumption you were using Eclipse as your IDE. Is that correct? If not, then what is "standard Kepler?"

    Regards,
    Jim
    The Java™ Tutorial | SSCCE | Java Naming Conventions
    Poor planning our your part does not constitute an emergency on my part.

  9. #9
    R03
    R03 is offline Member
    Join Date
    Apr 2014
    Posts
    10
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    Hi,
    I'm using eclipse kepler version too, if you download a new JDK (JDK 8) it's not fully compatible with eclipse..
    So eclipse will put out the warning, but it's still OK, you can ignore it the warning and you still compile your program..
    The problem is JDK 8 by default using JRE 1.4 i don't know why..


    Another option, just downgread your JDK to version 7, so your JRE will be version 1.7 or download new version of eclipse (code name : luna)

    Regards,
    R03.
    Last edited by R03; 04-29-2014 at 02:19 AM.

  10. #10
    wwwnews is offline Member
    Join Date
    Apr 2014
    Posts
    11
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    sorry I'm late, I'm johuar, but ma account was canceld yesterday, I send a message to the webmaster but have no answer till yet.
    I found out what jim829 meant with "Window -> preferences -> java -> ", I changed it to 1.6, restart eclipse, but it still doesnt except.

    Hi R03, ignore, mmh, well, but then I cant not run it? But I will look for new eclipse, I'm surprised that this eclipse wich I have is not actual.

    Maybe they canceld my account cause I'm using JonDonym, something whats hide you while you are surfing?

  11. #11
    wwwnews is offline Member
    Join Date
    Apr 2014
    Posts
    11
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    sorry I'm late, I'm joshuar, but my account was canceld yesterday, I send a message to the webmaster but have no answer till yet.
    I found out what jim829 meant with "Window -> preferences -> java -> ", I changed it to 1.6, restart eclipse, but it still doesnt except.

    Hi R03, ignore, mmh, well, but then I cant not run it? But I will look for new eclipse, I'm surprised that this eclipse wich I have is not actual.

    Maybe they canceld my account cause I'm using JonDonym, something whats hide you while you are surfing?

  12. #12
    jim829 is online now Senior Member
    Join Date
    Jan 2013
    Location
    Northern Virginia, United States
    Posts
    3,615
    Rep Power
    5

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    What Java runtime are you using? The JRE and the Compiler compliance level must match. If you changed them to 1.6 and are running 1.8 then it probably won't work. You need check the installed JRE's in the preferences section too.

    I find it strange they would cancel your account.

    Regards,
    Jim
    The Java™ Tutorial | SSCCE | Java Naming Conventions
    Poor planning our your part does not constitute an emergency on my part.

  13. #13
    wwwnews is offline Member
    Join Date
    Apr 2014
    Posts
    11
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    well, under "Installed JREs" i three columns Name="jre8default"
    Then under "Execution Enviroment" there is a long list like:
    - CDC-1.0/Foundation-1.0
    - CDC -1.1/Foundation-1.1
    - J2SE 1.2 till J2SE 1.5
    - JRE 1.1
    - JavaSE 1.6
    - JavaSE 1.7
    -Osgi Minimum -1.0 til Osgi Minimum 1.2

    so far as I understand I'm running JRE 1.1?
    But what else is to install, I did not made a special look, I just pikd up what was on top on those webpages.

  14. #14
    jim829 is online now Senior Member
    Join Date
    Jan 2013
    Location
    Northern Virginia, United States
    Posts
    3,615
    Rep Power
    5

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    JRE 1.1 is ancient. I suggest you choose either 1.6 or 1.7 and then make certain that you have your compliance level set to match. Kepler supports 1.8 but you must have service pack 2. I am running that now with no problems (yet). I would also recommend you make certain that your build paths were not modified to choose a project unique version. You can check this by right clicking on the project name in your project or package navigator.

    Regards,
    Jim
    The Java™ Tutorial | SSCCE | Java Naming Conventions
    Poor planning our your part does not constitute an emergency on my part.

  15. #15
    wwwnews is offline Member
    Join Date
    Apr 2014
    Posts
    11
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    well, I have no problem to agree, but is this what I need?
    Java Development Kit (32 bit) - Free download and software reviews - CNET Download.com

    cause, a jdk package (jdk-8u5-windows-x64), but eventhough its 1.1

  16. #16
    kneitzel is offline Senior Member
    Join Date
    Feb 2014
    Posts
    447
    Rep Power
    1

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    I am always wondering why people download software from such download portals. There is really no reason to use an of these sites!

    Java is a product from oracle. So just go to oracle.com and download java there. Then you can be quite sure that you
    - got the latest version
    - find other downloads related to it (e.g. samples or documentation)

    The java product can be directly found at Oracle and Java | Technologies | Oracle if you do not find Produkt -> Java on the main page

    Konrad

  17. #17
    wwwnews is offline Member
    Join Date
    Apr 2014
    Posts
    11
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    this "jdk-8u5-windows-x64" is from those oracle side. obviously not enough, posted in the first question of this thread.
    I'm always wondering why ist so hard to give simple answers.
    Last edited by wwwnews; 05-01-2014 at 03:57 AM.

  18. #18
    kneitzel is offline Senior Member
    Join Date
    Feb 2014
    Posts
    447
    Rep Power
    1

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    I am sorry if you found my reply not helpful.
    I answered in a post where you asked if the download of CNET.com is what you need. So a reply telling you that I see problems in such a site is quite valid. (And I left out security concerns that I hope are simply obvious!)
    The executable might be the one from oracle.com. It might have been altered. I don't know. I don't even care. But I hope you are not angry when I do not feel sorry with you if you become a victim of a computer crime because you started executables from locations where the trust level is not as high as it should be.

    I don't think that my reply was to complex. Maybe it wasn't the expected answer but please think about the security of your system and think twice what executables you download from where to execute on your system.

    Konrad

  19. #19
    gimbal2 is offline Just a guy
    Join Date
    Jun 2013
    Location
    Netherlands
    Posts
    4,029
    Rep Power
    6

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    Quote Originally Posted by wwwnews View Post
    I'm always wondering why ist so hard to give simple answers.
    Because people ask poor questions.
    "Syntactic sugar causes cancer of the semicolon." -- Alan Perlis

  20. #20
    wwwnews is offline Member
    Join Date
    Apr 2014
    Posts
    11
    Rep Power
    0

    Default Re: can't override a methode, it still ask for level 1.5 or greater

    I feel so overwalk by this smart answer.

    Something I have forgotten, after I figurd out "Window -> preferences -> java -> compiler", each one who carry about that at next, it is about eclipse.
    So, lets complite that: "open eclipse-> menü bar->Window -> preferences -> java -> compiler"

    IT-Foren are like a forecast of futureworld, the dictatorship we will probably have.
    Not possible that none of all users here, has any answer to my question.
    How many reasons we can count

Page 1 of 2 12 LastLast

Similar Threads

  1. overloading toString methode
    By faraa in forum New To Java
    Replies: 8
    Last Post: 05-02-2013, 10:08 PM
  2. EOF methode
    By Dipke in forum New To Java
    Replies: 7
    Last Post: 10-02-2010, 03:50 PM
  3. using paint methode in another class
    By imorio in forum New To Java
    Replies: 8
    Last Post: 08-12-2010, 03:17 PM
  4. calling methode with array
    By koddy in forum New To Java
    Replies: 0
    Last Post: 06-30-2010, 01:53 PM
  5. [SOLVED] Class-level vs Object-level method()
    By mfaizan24 in forum New To Java
    Replies: 7
    Last Post: 06-23-2009, 09:18 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •