Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By kneitzel

Thread: newbie eclipse errors

  1. #1
    fish72 is offline Member
    Join Date
    Apr 2014
    Posts
    2
    Rep Power
    0

    Default newbie eclipse errors

    I followed java programming for android developers for dummies book and installed java 7 update 55, Latest eclipse and the code that was on the book's site, And I'm getting some errors that seems like have to do with different eclipse version since book came out last year.
    I'm attaching the error log in hope someone can give me ideas on how to clear the errors before i proceed.

    Thank you
    Attached Files Attached Files

  2. #2
    kneitzel is offline Senior Member
    Join Date
    Feb 2014
    Posts
    447
    Rep Power
    1

    Default Re: newbie eclipse errors

    Hmm. I am just wondering: If oyu installed Java 1.7, then you have an JRE that is compliant to 1.6. It seems that eclipse is using an older Java only.

    You can tell eclipse about the installed environments at
    Window -> Preferences -> Java -> Installed JREs

    And when the installed JREs are there, you can tell eclipse what to use inside the project preferences.

    Also be aware: If you change the level you might need to change the JRE lib to use. (So as an example: When I updated a project to use 1.8 instead of 1.6 I also had to remove the 1.6 JRE library and add the 1.8 one!)

    With kind regards,

    Konrad
    fish72 likes this.

  3. #3
    fish72 is offline Member
    Join Date
    Apr 2014
    Posts
    2
    Rep Power
    0

    Default Re: newbie eclipse errors

    Hello Konard !

    First thank you for the tips. I managed to reduce number of errors by adding Java 1.6 build 45 to the installed JRE and by downloading twitter4j-core-3.0.3.jar and putting it in "c:\setups\twitter4j-3.0.3\lib\" folder.
    Now what I'll do is ask for the author of the codes about the rest of the errors, Because quickfix asks me to change some lines in the project's code and I prefer to wait-it-out instead to do some harsh mistake.

Similar Threads

  1. Eclipse is making me go silly with it's syntax errors
    By magicmojo in forum New To Java
    Replies: 5
    Last Post: 02-22-2011, 01:48 PM
  2. Errors Reported Using Eclipse
    By jkim1211a in forum New To Java
    Replies: 1
    Last Post: 11-06-2010, 06:33 PM
  3. Eclipse plugin, custom errors
    By X-ion in forum Eclipse
    Replies: 3
    Last Post: 02-22-2010, 11:24 AM
  4. eclipse 3.4 is shown errors
    By ramaksilvertide in forum New To Java
    Replies: 2
    Last Post: 02-09-2009, 11:51 PM
  5. newbie facing java errors
    By T2ml in forum New To Java
    Replies: 2
    Last Post: 11-29-2008, 06:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •