Results 1 to 4 of 4
  1. #1
    Gatsu is offline Member
    Join Date
    Dec 2012
    Posts
    42
    Rep Power
    0

    Default using javacv to display webcam works in IDE but not after export

    I have a problem where my webcam will not display after exporting a jar file.

    I export to runnable jar file
    I choose "package required libaries into generated jar"

    this are my imported libraries in Eclipse:

    using javacv to display webcam works in IDE but not after export-libraries.jpg

    What am I missing? No error messages and opencv is installed.
    Last edited by Gatsu; 11-01-2013 at 05:14 PM.

  2. #2
    gimbal2 is online now Just a guy
    Join Date
    Jun 2013
    Location
    Netherlands
    Posts
    3,900
    Rep Power
    5

    Default Re: using javacv to display webcam works in IDE but not after export

    How do you determine that you get no error messages? Have you tried to run the application from the command prompt so you can see any exceptions?

    EDIT:

    (using java -jar yourjar.jar)
    Last edited by gimbal2; 11-01-2013 at 05:24 PM.
    "Syntactic sugar causes cancer of the semicolon." -- Alan Perlis

  3. #3
    Gatsu is offline Member
    Join Date
    Dec 2012
    Posts
    42
    Rep Power
    0

    Default Re: using javacv to display webcam works in IDE but not after export

    I am using this to capture the error messages:
    JOptionPane.showMessageDialog(null, e);

    But when I did run "java -jar client.jar" from command prompt then the webcam works like it should! (no errors also)

    so what is the differens in just clicking it or running it like that?
    Last edited by Gatsu; 11-01-2013 at 07:39 PM.

  4. #4
    Gatsu is offline Member
    Join Date
    Dec 2012
    Posts
    42
    Rep Power
    0

    Default Re: using javacv to display webcam works in IDE but not after export

    I solved this by uninstalling jdk and reinstalling it! Thank you!

Similar Threads

  1. Using webcam with JMF
    By hkpn in forum New To Java
    Replies: 0
    Last Post: 09-20-2011, 03:45 PM
  2. Problem with display tag export option
    By g.raaja in forum Advanced Java
    Replies: 0
    Last Post: 06-04-2011, 11:16 AM
  3. Replies: 5
    Last Post: 06-02-2011, 06:59 AM
  4. Export view in display tag
    By sheila in forum JavaServer Pages (JSP) and JSTL
    Replies: 0
    Last Post: 02-24-2010, 03:12 PM
  5. J2ME Webcam 0.1
    By JavaBean in forum Java Software
    Replies: 0
    Last Post: 10-31-2007, 05:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •