Results 1 to 1 of 1
  1. #1
    Gowramma is offline Member
    Join Date
    May 2012
    Posts
    3
    Rep Power
    0

    Default java.lang.NoClassDefFoundError:

    I added a jar of my other project to the lib of my current project and I don't get the compilation error . when I am deploying I am getting the error

    ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/sunriseSunset]] Exception starting filter struts2
    java.lang.NoClassDefFoundError: com/vht/security/LoadSecurity


    I have also added the jar to the projects buildpath->libararies, and in order and export I have checked the jar check box.

    for your information I am using Eclipse IDE
    please , Let me know where I am going wrong.

    Thanks,
    Gowri
    Last edited by Gowramma; 05-02-2012 at 10:00 PM. Reason: more information about the question

Similar Threads

  1. Replies: 5
    Last Post: 06-02-2010, 02:05 PM
  2. Replies: 3
    Last Post: 06-01-2010, 04:01 PM
  3. java.lang.NoClassDefFoundError
    By AndrewM16921 in forum Java Applets
    Replies: 3
    Last Post: 09-29-2009, 07:54 PM
  4. java.lang.NoClassDefFoundError
    By J_a_y in forum New To Java
    Replies: 2
    Last Post: 08-07-2007, 12:51 PM
  5. java.lang.NoClassDefFoundError
    By fred in forum Advanced Java
    Replies: 3
    Last Post: 08-01-2007, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •