Results 1 to 8 of 8

Thread: JLayer

  1. #1
    wired-in=p is offline Member
    Join Date
    Jul 2011
    Posts
    38
    Rep Power
    0

    Default JLayer

    I am trying to use the JLayer and LayerUI class but eclipse keeps saying that it cannot be resolved. It also says that line i use to import the class is invalid. I recognize that it is in the new Java 7 package, so i downloaded the latest version of eclipse. Still, i cannot use the LayerUI class. What can i do?

  2. #2
    Fubarable's Avatar
    Fubarable is offline Moderator
    Join Date
    Jun 2008
    Posts
    19,316
    Blog Entries
    1
    Rep Power
    26

  3. #3
    wired-in=p is offline Member
    Join Date
    Jul 2011
    Posts
    38
    Rep Power
    0

    Default Re: JLayer

    What does that mean?

  4. #4
    Fubarable's Avatar
    Fubarable is offline Moderator
    Join Date
    Jun 2008
    Posts
    19,316
    Blog Entries
    1
    Rep Power
    26

    Default Re: JLayer

    Quote Originally Posted by wired-in=p View Post
    What does that mean?
    Check the properties of your Eclipse project (right click the project in the package explorer), then click on "Java Compiler", then check the JDK Compliance setting. Even if Eclipse is using Java 1.7, it can be set to compile at 1.5 or 1.6.

  5. #5
    wired-in=p is offline Member
    Join Date
    Jul 2011
    Posts
    38
    Rep Power
    0

    Default Re: JLayer

    Its set to 1.6

  6. #6
    Fubarable's Avatar
    Fubarable is offline Moderator
    Join Date
    Jun 2008
    Posts
    19,316
    Blog Entries
    1
    Rep Power
    26

  7. #7
    wired-in=p is offline Member
    Join Date
    Jul 2011
    Posts
    38
    Rep Power
    0

    Default Re: JLayer

    Alright, i set it to 1.7, but it still won't work. I think it is because the JRE I'm using is SE 6, and i don't know how to install SE 7.

  8. #8
    Fubarable's Avatar
    Fubarable is offline Moderator
    Join Date
    Jun 2008
    Posts
    19,316
    Blog Entries
    1
    Rep Power
    26

Similar Threads

  1. stoping playback of a mp3: javazooms JLayer
    By dko in forum Advanced Java
    Replies: 0
    Last Post: 05-16-2011, 06:24 AM
  2. Work with mp3 on JLayer
    By justinserg in forum New To Java
    Replies: 0
    Last Post: 05-03-2011, 10:19 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •