Results 1 to 4 of 4
  1. #1
    giladma is offline Member
    Join Date
    May 2011
    Posts
    3
    Rep Power
    0

    Default NetbBeans and Jar diffrence ?

    hey,
    i wrote small application that sends hebrew text to server, get response and write it to file that encoded in UTF8.
    When i run this application in the netBeans it works greate, but when i distributes the application and run the jar file from aside, i get the hebrew as gibrish.
    Any ideas ?
    10x.

  2. #2
    JosAH's Avatar
    JosAH is offline Moderator
    Join Date
    Sep 2008
    Location
    Voorschoten, the Netherlands
    Posts
    14,290
    Blog Entries
    7
    Rep Power
    24

    Default

    Quote Originally Posted by giladma View Post
    hey,
    i wrote small application that sends hebrew text to server, get response and write it to file that encoded in UTF8.
    When i run this application in the netBeans it works greate, but when i distributes the application and run the jar file from aside, i get the hebrew as gibrish.
    Any ideas ?
    10x.
    It's probably an encoding or font problem where Netbean's console is capable of displaying Hebrew while your system console isn't.

    kind regards,

    Jos
    The only person who got everything done by Friday was Robinson Crusoe.

  3. #3
    giladma is offline Member
    Join Date
    May 2011
    Posts
    3
    Rep Power
    0

    Default

    10x for the response.

    but, i don't think that the problem is in the encoding of the system console. In previous version in a local version of the thing that i now run as server and it worked fine. The only change that i did is to use somthing as server and not local.

  4. #4
    JosAH's Avatar
    JosAH is offline Moderator
    Join Date
    Sep 2008
    Location
    Voorschoten, the Netherlands
    Posts
    14,290
    Blog Entries
    7
    Rep Power
    24

    Default

    Quote Originally Posted by giladma View Post
    10x for the response.

    but, i don't think that the problem is in the encoding of the system console. In previous version in a local version of the thing that i now run as server and it worked fine. The only change that i did is to use somthing as server and not local.
    Do these Hebrew characters go over the wire, i.e. are they being sent from a server to a client or vice versa? Maybe it's the encoding there, i.e. the OutputStreams and/or InputStreams don't transport the correctly encoded characters.

    kind regards,

    Jos
    The only person who got everything done by Friday was Robinson Crusoe.

Similar Threads

  1. Replies: 3
    Last Post: 11-04-2010, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •