Results 1 to 5 of 5

Thread: Package problem

  1. #1
    Vizualni is offline Member
    Join Date
    Jul 2010
    Posts
    10
    Rep Power
    0

    Default Package problem

    Hello. I've made some java app and I've used org.apache...httpclient etc etc. Then I've made other project (in netbeans. First project was also made in netbeans) and I couldn't find apache package. It was like it works only on that first project. And I've never downloaded apache library before.

    How can I fix this?

    Thanks :)

  2. #2
    JosAH's Avatar
    JosAH is offline Moderator
    Join Date
    Sep 2008
    Location
    Voorschoten, the Netherlands
    Posts
    13,679
    Blog Entries
    7
    Rep Power
    21

    Default

    Quote Originally Posted by Vizualni View Post
    Hello. I've made some java app and I've used org.apache...httpclient etc etc. Then I've made other project (in netbeans. First project was also made in netbeans) and I couldn't find apache package. It was like it works only on that first project. And I've never downloaded apache library before.

    How can I fix this?
    You must've downloaded that library (a .jar) at least once otherwise your first project wouldn't have run. Check the settings for your first project; it mentions that jar somewhere; adjust the settings for your second project accordingly.

    kind regards,

    Jos

  3. #3
    Eranga's Avatar
    Eranga is offline Moderator
    Join Date
    Jul 2007
    Location
    Colombo, Sri Lanka
    Posts
    11,372
    Blog Entries
    1
    Rep Power
    20

    Default

    Probably rather adding them into the classpath, you may added into only the first project. Otherwise how it could be possible to run the first project, but not the second. Check about it.

  4. #4
    Vizualni is offline Member
    Join Date
    Jul 2010
    Posts
    10
    Rep Power
    0

    Default

    Thanks guys. That library was actually inside other library I've included in my first project. Thanks again :)

  5. #5
    Eranga's Avatar
    Eranga is offline Moderator
    Join Date
    Jul 2007
    Location
    Colombo, Sri Lanka
    Posts
    11,372
    Blog Entries
    1
    Rep Power
    20

Similar Threads

  1. Facing problem in compiling user defined package
    By UJJAL DHAR in forum New To Java
    Replies: 2
    Last Post: 05-24-2010, 12:40 PM
  2. Replies: 7
    Last Post: 11-09-2009, 08:51 AM
  3. Client to Server, ClassNotFound Package Problem
    By pwnzer in forum New To Java
    Replies: 3
    Last Post: 11-07-2009, 10:17 PM
  4. problem with PrintService in javax.print package
    By sandeepsai17 in forum New To Java
    Replies: 0
    Last Post: 07-13-2009, 11:27 AM
  5. Problem With Package
    By acp26b in forum New To Java
    Replies: 3
    Last Post: 07-14-2008, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •