Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2008
    Posts
    25
    Rep Power
    0

    Default [SOLVED] j2me button/command problem

    Hello Everybody,

    i have have developed a j2me app through the wtk. i can navigate through the phone menu ok but after i have executed some data to a servlet, when i go back to the main menu, it is unresponsive to the click. the app still runs and but is no action when the button is clicked?

    any ideas what causes this problems?

    thanks

  2. #2
    Join Date
    Mar 2008
    Posts
    25
    Rep Power
    0

    Default

    i've narrowed the problem down to when the form appends the radio button:

    so something like...

    Form Status = new Form("Change Status..");
    ...
    Status.append(radButtons);

    so its there, on the status append after the second time round of calling the form does it throw:

    java.lang.IllegalStateException

    any help welcomed

  3. #3
    Join Date
    Mar 2008
    Posts
    25
    Rep Power
    0

    Default

    if the radio buttons are used in a form and the form is used again, make sure the radio buttons are declared within the menu, then they are fresh everytime they are re-used and wont throw an error...happy days

Similar Threads

  1. Problem With POST command to control the network camera
    By sri_reddy523 in forum Networking
    Replies: 3
    Last Post: 03-16-2009, 06:53 AM
  2. problem on button
    By udayforu_1986 in forum Java Applets
    Replies: 1
    Last Post: 08-03-2008, 01:57 PM
  3. Replies: 0
    Last Post: 06-20-2008, 09:02 AM
  4. Problem during executing Command Prompt
    By keshari in forum Advanced Java
    Replies: 4
    Last Post: 06-05-2008, 04:06 AM
  5. Replies: 2
    Last Post: 08-06-2007, 09:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •