Results 1 to 5 of 5

Thread: ant build

  1. #1
    sardare is offline Member
    Join Date
    Jun 2008
    Posts
    17
    Rep Power
    0

    Default ant build

    Hello,
    I set JAVA_HOME to point to my local installation to 1.6 java. But ant is still detecting system java 1.5

    Apache Ant version 1.7.0 compiled on July 26 2007
    Buildfile: build.xml
    Detected Java version: 1.5 in: /opt/sun-jdk-1.5.0.12/jre
    Detected OS: Linux
    parsing buildfile /mnt/d1/home/sjain/medium/svn/medium/build.xml with URI = file:/mnt/d1/home/sjain/medium/svn/medium/build.xml

    HOw to change this? I have tried everything...is there way to make this work at all?

  2. #2
    mcfrog's Avatar
    mcfrog is offline Member
    Join Date
    Apr 2009
    Location
    Germany
    Posts
    32
    Rep Power
    0

    Default

    hi,

    perhaps your classpath is set to jre 1.5 libraries? Alternatively I can imagine that you can enter a jre path inside the ant script.

    I am at home, so I can't look into my own ant script which was set up some time ago...
    Cheers / beste Gre / lepo pozdravje
    8=:(=)D . o O ( Save the Giraffes )

  3. #3
    sardare is offline Member
    Join Date
    Jun 2008
    Posts
    17
    Rep Power
    0

    Default

    Ok thanks.
    Another question is how does ANT handle dependecies between packages? Do I need to specify it or it figures it out by itself?
    I keep getting compilation errors due to missing symbols as there are dependencies within my source tree.

    Quote Originally Posted by mcfrog View Post
    hi,

    perhaps your classpath is set to jre 1.5 libraries? Alternatively I can imagine that you can enter a jre path inside the ant script.

    I am at home, so I can't look into my own ant script which was set up some time ago...

  4. #4
    mcfrog's Avatar
    mcfrog is offline Member
    Join Date
    Apr 2009
    Location
    Germany
    Posts
    32
    Rep Power
    0

    Default

    Nice that my advice helped. Hmm, I have no answers regarding the dependencies.

    But you should consider to mention what of my two suggestions really made it to the solution. This way you provide a help for everyone ;)
    Cheers / beste Gre / lepo pozdravje
    8=:(=)D . o O ( Save the Giraffes )

  5. #5
    sardare is offline Member
    Join Date
    Jun 2008
    Posts
    17
    Rep Power
    0

    Default

    Actually after I set JAVA_HOME, it seemed to work. I was confusing the compilation errors coming from dependencies and not due to wrong version.

    Quote Originally Posted by mcfrog View Post
    Nice that my advice helped. Hmm, I have no answers regarding the dependencies.

    But you should consider to mention what of my two suggestions really made it to the solution. This way you provide a help for everyone ;)

Similar Threads

  1. know about how to build JSF app in NETBEANS IDE
    By vasanthathatha in forum JavaServer Faces (JSF)
    Replies: 2
    Last Post: 05-06-2009, 11:26 AM
  2. Unable to build
    By jkeller in forum Eclipse
    Replies: 1
    Last Post: 01-15-2009, 06:56 PM
  3. various stuffs to build GUI
    By Devi in forum AWT / Swing
    Replies: 1
    Last Post: 12-01-2008, 07:04 PM
  4. clean and Build
    By bhanu in forum Eclipse
    Replies: 3
    Last Post: 07-03-2008, 01:13 PM
  5. Replies: 0
    Last Post: 06-11-2008, 01:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •