Results 1 to 3 of 3
  1. #1
    ravi is offline Member
    Join Date
    Nov 2008
    Posts
    2
    Rep Power
    0

    Default INFO About JDK1.6

    Hi ,
    This is Ravi, i am using the jdk1.5 version thats working fine, i will change the my jdkversion to jdk1.6 in Eclipse and JRE also jre6 ,but compilation time i have error
    'enum' should not be used as an identifier, since it is a reserved keyword from source level 5.0 , in using jdk1.6
    how to resolve that error,please replay as soon as possible


    Regards,
    Ravi

  2. #2
    Eranga's Avatar
    Eranga is offline Moderator
    Join Date
    Jul 2007
    Location
    Colombo, Sri Lanka
    Posts
    11,372
    Blog Entries
    1
    Rep Power
    20

    Default

    Can you show your code segment which you get this error. May be you are using a deprecate methods or something.

  3. #3
    Norm's Avatar
    Norm is offline Moderator
    Join Date
    Jun 2008
    Location
    Eastern Florida
    Posts
    17,562
    Rep Power
    25

    Default

    how to resolve that error
    Rename all variables named enum to something else.

Similar Threads

  1. Difference between jdk1.5 and jdk1.6
    By pradnya in forum New To Java
    Replies: 10
    Last Post: 12-08-2010, 11:52 AM
  2. [SOLVED] Backporting Struts 2 to JDK1.4
    By piyu.sha in forum Advanced Java
    Replies: 3
    Last Post: 10-06-2008, 12:08 AM
  3. What is JDK1.5?
    By pawankumarom in forum New To Java
    Replies: 2
    Last Post: 09-05-2008, 07:41 AM
  4. possible feature of jdk1.7
    By sikandar in forum Advanced Java
    Replies: 2
    Last Post: 09-05-2008, 07:21 AM
  5. Replies: 1
    Last Post: 05-27-2008, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •