Results 1 to 3 of 3
  1. #1
    Stoyicker is offline Member
    Join Date
    Jan 2012
    Posts
    32
    Rep Power
    0

    Default JMF not working from inside Netbeans

    Hello.

    I'm now working on sound playing. For that purpose, I'm using JMF. I've already installed it, and choosing all and everyone of the recommended options while installing (like auto-updating CLASSPATH, for example). After compiling my class AudioSample, indicated in the IBM DeveloperWorks tutorial for JMF with the javac command, if I try to run it from the command line it works perfect. But that's not what I want. I need it to be able to run from inside my Netbeans IDE, because I want to include it in a library, what of course implies building it as a .jar. The problem is that it doesn't work when I run it from my IDE because the .jar doesn't work (if I double-click it, it doesn't work). So, as expectable, I get an error when I try to run a sound file from that library:

    Unable to handle format: LINEAR, 48000.0 Hz, 24-bit, Stereo, LittleEndian, Signed, 288000.0 frame rate, FrameSize=48 bits
    Failed to prefetch: com.sun.media.PlaybackEngine@7259da
    Error: Unable to prefetch com.sun.media.PlaybackEngine@7259da

    But, if I compile from command line the single class and try it from the command line, it works fine.

    So please I'd need some help. I've already tried adding some stuff to classpath but it doesn't work. I'm using Netbeans IDE and this is the structure of my work:

    Attachment 2654

  2. #2
    Stoyicker is offline Member
    Join Date
    Jan 2012
    Posts
    32
    Rep Power
    0

    Default Re: JMF not working from inside Netbeans

    Please someone allowed to, close/delete this topic. I've already found an alternative solution.

  3. #3
    DarrylBurke's Avatar
    DarrylBurke is offline Member
    Join Date
    Sep 2008
    Location
    Madgaon, Goa, India
    Posts
    11,188
    Rep Power
    19

    Default Re: JMF not working from inside Netbeans

    Quote Originally Posted by Stoyicker View Post
    I've already found an alternative solution.
    And you will share it with the forum, won't you? for the benefit of the next person who faces the same problem.

    db
    If you're forever cleaning cobwebs, it's time to get rid of the spiders.

Similar Threads

  1. NetBeans IDE not working properly
    By farmer in forum NetBeans
    Replies: 2
    Last Post: 12-09-2011, 03:12 PM
  2. Replies: 6
    Last Post: 04-06-2011, 12:39 PM
  3. Replies: 0
    Last Post: 02-21-2011, 09:36 AM
  4. Problem with .jar working with netbeans
    By chipimdp in forum NetBeans
    Replies: 1
    Last Post: 05-14-2010, 09:25 AM
  5. Replies: 2
    Last Post: 03-16-2009, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •