Results 1 to 2 of 2
  1. #1
    mikeotieno is offline Member
    Join Date
    Jan 2011
    Rep Power

    Default J2ME-Emulator Error


    I am new to NetBeans. I have just written my first application "Hello World" to test the IDE and am getting the below error please help. Am running NetBeans IDE 6.9.1

    java.lang.UnsatisfiedLinkError: /home/mike/netbeans-6.9.1/mobility/WTK2.5.2/bin/ /home/mike/netbeans-6.9.1/mobility/WTK2.5.2/bin/ wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1750)
    at java.lang.ClassLoader.loadLibrary( :1646)
    at java.lang.Runtime.load0(
    at java.lang.System.load(
    at com.sun.kvem.Sublime.<init>(Unknown Source)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(
    at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(
    at java.lang.reflect.Constructor.newInstance(Construc
    at java.lang.Class.newInstance0(
    at java.lang.Class.newInstance(
    at com.sun.kvem.Lime.createLime(Unknown Source)
    at com.sun.kvem.KVMBridge.<init>(Unknown Source)
    at com.sun.kvem.KVMBridge.getBridge(Unknown Source)
    at Source)
    at com.sun.kvem.environment.EmulatorInvoker.runEmulat orImpl(Unknown Source)
    at com.sun.kvem.environment.EmulatorInvoker.main(Unkn own Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
    at java.lang.reflect.Method.invoke(
    at com.sun.kvem.environment.JVM.main(Unknown Source)
    /home/mike/NetBeansProjects/MyHelloMIDlet/nbproject/build-impl.xml:898: Execution failed with error code 1.
    BUILD FAILED (total time: 2 seconds)

  2. #2
    javiertoquica is offline Member
    Join Date
    May 2012
    Rep Power

    Default Re: J2ME-Emulator Error


    im having the same problem. so, how did you solved it?


Similar Threads

  1. web server error for J2ME application
    By vishal21 in forum CLDC and MIDP
    Replies: 5
    Last Post: 01-04-2011, 09:19 PM
  2. web server error for J2ME application
    By vishal21 in forum CDC and Personal Profile
    Replies: 0
    Last Post: 01-02-2011, 08:09 PM
  3. Emulator
    By pabloma2002 in forum New To Java
    Replies: 5
    Last Post: 12-29-2010, 03:33 AM
  4. Error when build by j2me wireless toolkit
    By matvey in forum Sun Java Wireless Toolkit
    Replies: 3
    Last Post: 10-23-2009, 06:34 PM
  5. certificate error
    By asdfghjkl in forum CLDC and MIDP
    Replies: 1
    Last Post: 11-09-2007, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts