Results 1 to 4 of 4
  1. #1
    simon is offline Member
    Join Date
    Jul 2007
    Posts
    44
    Rep Power
    0

    Default NoClassDefFoundError: org/hibernate/Session

    I'm using struts and hibernate and when I run the application this error appears:
    Java Code:
    
    Error 500--Internal Server Error
    java.lang.NoClassDefFoundError: org/hibernate/Session
    at struts.action.inputAction.execute(inputAction.java:33)
    at org.apache.struts.action.RequestProcessor.processActionPerform
    (RequestProcessor.java:484)
    at org.apache.struts.action.RequestProcessor.process
    (RequestProcessor.java:274)
    at org.apache.struts.action.ActionServlet.process
    (ActionServlet.java:1482)
    at org.apache.struts.action.ActionServlet.doPost
    (ActionServlet.java:525)
    at javax.servlet.http.HttpServlet.service
    (HttpServlet.java:760)
    at javax.servlet.http.HttpServlet.service
    (HttpServlet.java:853)
    at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run
    (ServletStubImpl.java:971)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet
    (ServletStubImpl.java:402)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet
    (ServletStubImpl.java:305)
    at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run
    (WebAppServletContext.java:6350)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs
    (AuthenticatedSubject.java:317)
    at weblogic.security.service.SecurityManager.runAs
    (SecurityManager.java:118)
    at weblogic.servlet.internal.WebAppServletContext.invokeServlet
    (WebAppServletContext.java:3635)
    at weblogic.servlet.internal.ServletRequestImpl.execute
    (ServletRequestImpl.java:2585)
    at weblogic.kernel.ExecuteThread.execute
    (ExecuteThread.java:197)
    at weblogic.kernel.ExecuteThread.run
    (ExecuteThread.java:170)
    any ideas?

  2. #2
    mary is offline Member
    Join Date
    Jul 2007
    Posts
    51
    Rep Power
    0

    Default

    I have had a similar problem
    there weren't some jars deployed
    check it

  3. #3
    arfatkhan is offline Member
    Join Date
    Jul 2007
    Posts
    9
    Rep Power
    0

    Default

    have you included the hibernate.jar ?

  4. #4
    simon is offline Member
    Join Date
    Jul 2007
    Posts
    44
    Rep Power
    0

Similar Threads

  1. Replies: 2
    Last Post: 07-21-2012, 01:15 AM
  2. java.lang.NoClassDefFoundError: com.ibm.ws.orb.GlobalORBFactory
    By hawkeye in forum Enterprise JavaBeans (EJB)
    Replies: 1
    Last Post: 06-16-2008, 10:56 AM
  3. java.lang.NoClassDefFoundError
    By J_a_y in forum New To Java
    Replies: 2
    Last Post: 08-07-2007, 11:51 AM
  4. java.lang.NoClassDefFoundError
    By fred in forum Advanced Java
    Replies: 3
    Last Post: 08-01-2007, 05:00 PM
  5. Replies: 2
    Last Post: 06-30-2007, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •