Results 1 to 1 of 1
  1. #1
    ShinTec's Avatar
    ShinTec is offline Member
    Join Date
    Jan 2010
    Posts
    51
    Rep Power
    0

    Exclamation Cannot Get gif to show on webpage

    Hi Forum
    Im running into some problems getting a gif to display on a web page The web page works but the gif doesnt show on it dont know whats wrong
    Using JSF 2.0, eclipse Helios , Tomcat 6.0

    ================
    hello.xhtml file
    ===============
    XML Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml"
          xmlns:f="http://java.sun.com/jsf/core"      
          xmlns:h="http://java.sun.com/jsf/html">
        <f:view contentType="text/html"/>
        <h:head>
            <title>Hello World!</title>
        </h:head>
        <h:body bgcolor="white">
            <h2>My name is Duke.  What is yours?</h2>
            <h:form id="helloForm" >
                <h:graphicImage id="waveImg" url="#{resources['Goku.gif']}" />
                <h:inputText id="username" value="#{helloBean.name}"/>
                <h:commandButton id="submit" action="response" value="Submit"/>
            </h:form>
        </h:body>
    </html>
    =====================
    response.xhtml
    =====================
    XML Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml"
          xmlns:f="http://java.sun.com/jsf/core"      
          xmlns:h="http://java.sun.com/jsf/html">
    <f:view contentType="text/html; charset=iso-8859-1"/>
    <head><title>Response</title></head>
    <body>
        <h:form id="responseform">
        <h:graphicImage id="waveImg" url="#{resources['Goku.gif']}" />
        <h2>Hi, #{helloBean.name}</h2>
          <h:commandButton id="back" value="Back" action="hello" />
        </h:form>
    </body>
    </html>
    Any help would be much appreciated and thank you in advance
    Last edited by ShinTec; 09-26-2010 at 02:46 PM. Reason: grammar errors

Similar Threads

  1. Replies: 3
    Last Post: 05-27-2010, 11:54 AM
  2. Add a Swing UI in a WebPage
    By ivvgangadhar in forum AWT / Swing
    Replies: 9
    Last Post: 06-30-2009, 09:16 AM
  3. save a webpage.....?
    By 05bit044 in forum Networking
    Replies: 1
    Last Post: 08-04-2008, 05:49 PM
  4. post info to a webpage
    By kmp in forum Networking
    Replies: 1
    Last Post: 03-22-2008, 03:20 AM
  5. netbeans 6.0 not show commpunent or show blank page
    By fahimaamir in forum NetBeans
    Replies: 1
    Last Post: 01-26-2008, 07:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •