I am working on jdk and Tomcat migration from 1.4 to 1.6 and from 4.1 to 5.5 respectively.

I have modified the code such that it follows jdk1.6 specifications and moved the code to UAT.

I have also changed the Tomcat version from 4.1 to 5.5 and jdk version from 1.4 to 1.6 under Tomcat Configuration through UI.

While testing, I have found that none of the servlet classes are successfully called, rather it is throwing the following error:
"The requested resource is not available".

--------------------------------
HTTP Status 404 - Servlet TabViewDisplay is not available
type Status report
message TabViewDisplay is not available
description The requested resource (Servlet TabViewDisplay is not available) is not available.
Apache Tomcat/5.5
---------------------------------

Scenario:
I am accessing the servlet TabViewDisplay which is available in the context abc as: URL/abc/TabViewDisplay

web.xml is in the following manner:
<servlet>
<servlet-name>TabViewDisplay</servlet-name>
<servlet-class>com.servlet.TabViewDisplay</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>TabViewDisplay</servlet-name>
<url-pattern>/TabViewDisplay</url-pattern>
</servlet-mapping>

Before migration, this servlet has been successfully called. Facing this problem only after the migration of Tomcat from 4.4 to 5.5.

Could anyone please let us know what might be the problem.