Results 1 to 4 of 4
  1. #1
    mvv
    mvv is offline Member
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    0

    Default SEVERE: Error filterStart

    Hi all,

    I've been trying to get a Java servlet going on Tomcat 6 but I get stuck with the following error:

    Java Code:
    Apr 1, 2009 1:16:21 PM org.apache.catalina.core.StandardContext start
    SEVERE: Error filterStart
    Different example servlets do work so I think it is a issue with the web.xml file of this specific servlet. But I am no Java dev so I do not understand much of the code. Is there a way for me to troubleshoot this? I've tried increasing the log level, all it gave me was too many logs.

    I hope someone here can point me in the right direction, many thanks in advance for any help on this. :)

  2. #2
    serjant's Avatar
    serjant is offline Senior Member
    Join Date
    Jun 2008
    Location
    Ukraine,Zaporozhye
    Posts
    487
    Rep Power
    7

    Default

    Check your web.xml file, can you post it here?

  3. #3
    mvv
    mvv is offline Member
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    0

    Default

    Hi, thanks for your reply, I just solved the issue yesterday. It turned out I compiled the servlet the wrong way. I compiled with "ant war" instead of "ant compile". The servlet loads fine now, thanks again :)

  4. #4
    pkoppall is offline Member
    Join Date
    Jan 2010
    Posts
    1
    Rep Power
    0

    Default

    I was trying to deploy one of my web application and got filter start error,Hence i stuckk here..please help go further..
    Please see my web.xml file


    ---------------------------------------------
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
    "http://java.sun.com/dtd/web-app_2_3.dtd">

    <web-app>

    <display-name>Servlet 2.4 Examples</display-name>
    <description>Servlet 2.4 Examples.</description>

    <!--<filter>
    <filter-name>HeaderFilter</filter-name>
    <filter-class>com.netegrity.was511.filter.ServletFilter</filter-class>
    </filter>

    <filter>
    <filter-name>CCXSiteminderFilter</filter-name>
    <filter-class>com.netegrity.was511.filter.ServletFilter</filter-class>
    </filter>-->


    <!-- <filter>
    <filter-name>AccessLogFilter</filter-name>
    <filter-class>com.cisco.tools.filter.AccessLogFilter</filter-class>
    </filter>

    <filter-mapping>
    <filter-name>AccessLogFilter</filter-name>
    <url-pattern>/*</url-pattern>
    </filter-mapping>

    <filter-mapping>
    <filter-name>HeaderFilter</filter-name>
    <url-pattern>/*</url-pattern>
    </filter-mapping>

    <filter-mapping>
    <filter-name>CCXSiteminderFilter</filter-name>
    <url-pattern>/*</url-pattern>
    </filter-mapping> -->

    <servlet>
    <servlet-name>ICITServlet</servlet-name>
    <servlet-class>
    com.cisco.icit.application.servlet.ICITServlet
    </servlet-class>
    <init-param>
    <param-name>Params.SERVER_DB_FILE</param-name>
    <param-value>CommonDB.properties</param-value>
    </init-param>
    <init-param>
    <param-name>Params.EMAILSERVER</param-name>
    <param-value>email.properties</param-value>
    </init-param>

    <init-param>
    <param-name>Params.MAILER_PROPS</param-name>
    <param-value>Mailer.properties</param-value>
    </init-param>
    <init-param>
    <param-name>Params.APPLICATION_LIST</param-name>
    <param-value>
    ca.properties;ipc.properties;npmr.properties;equip .properties;ctmp.properties;cnd.properties;qic.pro perties
    </param-value>
    </init-param>
    <init-param>
    <param-name>SHOW_PRINTS</param-name>
    <param-value>true</param-value>
    </init-param>
    <init-param>
    <param-name>SHOW_ERRORS</param-name>
    <param-value>true</param-value>
    </init-param>
    <init-param>
    <param-name>OMIT_DB</param-name>
    <param-value>true</param-value>
    </init-param>
    <init-param>
    <param-name>NEED_SECURITY</param-name>
    <param-value>true</param-value>
    </init-param>
    <init-param>
    <param-name>Params.EXCEPTION_PROPERTIES_PATH</param-name>
    <param-value>ExceptionStyleSheet.properties</param-value>
    </init-param>
    <init-param>
    <param-name>LogDirectory</param-name>
    <param-value>logs</param-value>
    </init-param>

    <init-param>
    <param-name>ServletName</param-name>
    <param-value>ICITServlet</param-value>
    </init-param>
    </servlet>
    <servlet-mapping>
    <servlet-name>ICITServlet</servlet-name>
    <url-pattern>/ICITServlet</url-pattern>
    </servlet-mapping>

    <!-- "Force CCO authentication" -->

    <!-- <security-constraint>
    <web-resource-collection>
    <web-resource-name>CCO</web-resource-name>
    <url-pattern>/*</url-pattern>
    </web-resource-collection>

    <auth-constraint>
    <role-name>smx_grant_role</role-name>
    <role-name>unprot_role</role-name>
    <role-name>ignore_ext_role</role-name>
    </auth-constraint>
    </security-constraint>

    <login-config>
    <auth-method>BASIC</auth-method>
    <realm-name>CCO</realm-name>
    </login-config> -->
    <!--Begin Changes April09 MR TD2645 -->

    <filter>
    <filter-name>XSS</filter-name>
    <display-name>XSS</display-name>
    <filter-class>
    com.cisco.icit.application.servlet.CrossScriptingF ilter
    </filter-class>
    </filter>
    <!--Begin Changes April09 MR TD2358 -->

    <!--Begin Changes April09 MR TD2645 -->
    <filter-mapping>
    <filter-name>XSS</filter-name>
    <url-pattern>/*</url-pattern>
    </filter-mapping>
    <!--End Changes April09 MR TD2645 -->

    </web-app>
    ---------------------------------------

    Error:Jan 15, 2010 7:47:51 AM org.apache.catalina.core.StandardContext start
    SEVERE: Error filterStart
    Jan 15, 2010 7:47:51 AM org.apache.catalina.core.StandardContext start
    SEVERE: Context startup failed due to previous errors


    Help me..
    Thanks.

Similar Threads

  1. Replies: 3
    Last Post: 01-23-2009, 09:53 AM
  2. error 530 error authentication required
    By rgale in forum JavaServer Pages (JSP) and JSTL
    Replies: 0
    Last Post: 05-12-2008, 05:28 PM
  3. Tomcat Server : Error filterStart
    By kasipandian in forum Web Frameworks
    Replies: 0
    Last Post: 03-30-2008, 04:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •