Results 1 to 9 of 9
  1. #1
    Maisondouf's Avatar
    Maisondouf is offline Member
    Join Date
    Dec 2011
    Location
    Bordeaux, France
    Posts
    7
    Rep Power
    0

    Default Applet run differently under w7 and Linux

    I try to update an old applet which is online since 8 months because with new JRE 7 its behaviour is instable.
    As you can see on a W7 PC with jre7.0_07, the two uppers JTextArea are duplicate.

    But not on a linux PC with the same version of JRE


    I have tried on another pc with W7 but with JRE6.0_35 and the display bug doesn't appear.
    All my background are transparent ( Color(0,0,0,0) ), but if I set them to lightGray (or another color), the display is correct.

    Somebody have an idea to force display to be good ???

    Thanks in advance.

    NB: the applet could be launched HERE.
    Last edited by Maisondouf; 09-04-2012 at 11:48 PM.

  2. #2
    DarrylBurke's Avatar
    DarrylBurke is offline Member
    Join Date
    Sep 2008
    Location
    Madgaon, Goa, India
    Posts
    11,188
    Rep Power
    19

    Default Re: Applet run differently under w7 and Linux

    To get better help sooner, post a SSCCE (Short, Self Contained, Correct (Compilable), Example) that demonstrates the problem.

    db
    If you're forever cleaning cobwebs, it's time to get rid of the spiders.

  3. #3
    Maisondouf's Avatar
    Maisondouf is offline Member
    Join Date
    Dec 2011
    Location
    Bordeaux, France
    Posts
    7
    Rep Power
    0

    Default Re: Applet run differently under w7 and Linux

    Yes I wish, but I don't know where to begin...

    If I can locate the code portion where the problem is, it's sure that's will be better to debug....

    And I not sure to be able to "demonstrate" the problem, I'm not Einstein

    All I can says is what I see and all I can hope is that somebody here have seen the same behaviour and had correct it.

  4. #4
    Maisondouf's Avatar
    Maisondouf is offline Member
    Join Date
    Dec 2011
    Location
    Bordeaux, France
    Posts
    7
    Rep Power
    0

    Default Re: Applet run differently under w7 and Linux

    The new think I discover it's when I drop down in the task bar my browser with the display bug and then I re-open it the display is good and the bug has disappered.

  5. #5
    Maisondouf's Avatar
    Maisondouf is offline Member
    Join Date
    Dec 2011
    Location
    Bordeaux, France
    Posts
    7
    Rep Power
    0

    Default Re: Applet run differently under w7 and Linux

    The same thing if in your browser you have more than one tab, if you swtich to another tab and come back to the applet tab, the bug have disappeared....

  6. #6
    DarrylBurke's Avatar
    DarrylBurke is offline Member
    Join Date
    Sep 2008
    Location
    Madgaon, Goa, India
    Posts
    11,188
    Rep Power
    19

    Default Re: Applet run differently under w7 and Linux

    -- Applet or JApplet? If this is old (very old!) AWT code, I totally recommend porting it to Swing.
    -- Take care to ensure that there is no violation of Swing's single threaded rule (search the net if you don't know about it).

    db
    If you're forever cleaning cobwebs, it's time to get rid of the spiders.

  7. #7
    Maisondouf's Avatar
    Maisondouf is offline Member
    Join Date
    Dec 2011
    Location
    Bordeaux, France
    Posts
    7
    Rep Power
    0

    Default Re: Applet run differently under w7 and Linux

    It's JApplet.
    Java Code:
    package chrono4;
    import java.util.Locale;
    import java.util.ResourceBundle;
    import javax.swing.JApplet;
    import javax.swing.SwingUtilities;
    
    public class C4_Applet extends JApplet {
    I don't know about single thread violation, I will look for...

    Thanks

  8. #8
    Maisondouf's Avatar
    Maisondouf is offline Member
    Join Date
    Dec 2011
    Location
    Bordeaux, France
    Posts
    7
    Rep Power
    0

    Default Re: Applet run differently under w7 and Linux

    After reading a lot of pages, I know more about EDT, realizable, invokeLater and so on...

    But I don't see where in my code I can produce a thread violation, all the operations are very sequencial and only the three buttons produce events.

    An other new about testing, the bug apears only on PC with NVIDIA graphic card....

    I had called some of my friend to lauch the applet on her PC and say me if the bug is present, all of them with NVIDIA card (and latest driver) say YES.

  9. #9
    DarrylBurke's Avatar
    DarrylBurke is offline Member
    Join Date
    Sep 2008
    Location
    Madgaon, Goa, India
    Posts
    11,188
    Rep Power
    19

    Default Re: Applet run differently under w7 and Linux

    Ensure that the video drivers are updated to the latest available versions.

    db
    If you're forever cleaning cobwebs, it's time to get rid of the spiders.

Similar Threads

  1. Replies: 0
    Last Post: 03-15-2012, 01:13 PM
  2. Replies: 1
    Last Post: 04-27-2011, 10:08 AM
  3. Java Applet Error at Eclipse on Linux Ubuntu
    By bytescode in forum Java Applets
    Replies: 2
    Last Post: 01-31-2011, 09:49 AM
  4. Replies: 6
    Last Post: 04-08-2009, 04:05 AM
  5. displaying error messages differently
    By Jothi in forum JavaServer Faces (JSF)
    Replies: 0
    Last Post: 05-20-2008, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •