Results 1 to 5 of 5
  1. #1
    psbhat is offline Member
    Join Date
    Feb 2012
    Posts
    2
    Rep Power
    0

    Default Aplet not loading on java 1.7

    We have a web application(having applets) which used to run on java 1.6 update2 + windows XP + Internet explorer 7

    Now the system has been upgraded to java 1.7 + windows 7 + Internet explorer 8 because of which the application is not opening and the web page becomes unresponsive.

    After browsing for solution from web, i found that the problem might be due to the latest Next genaration plugin(introduced after java 1.6 update 10) for appplets. I disabled the Next Geneartion plugin using java control panel. But still its the same problem. When i collected the java console logs, it doesn't show any major exceptions other than the following:

    iveconnect: Invoking JS method: document
    liveconnect: Invoking JS method: URL
    java.net.MalformedURLException: no protocol:
    at java.net.URL.<init>(Unknown Source)
    at java.net.URL.<init>(Unknown Source)
    at com.sun.deploy.uitoolkit.impl.awt.AWTDefaultPreloa der$GrayBoxPainterStarter.run(Unknown Source)

    Please note that application runs fine with windows7 + java 1.6 + internet explorer 8.

    Please suggest what can be done and also let me know if you need more details.

  2. #2
    DarrylBurke's Avatar
    DarrylBurke is offline Member
    Join Date
    Sep 2008
    Location
    Madgaon, Goa, India
    Posts
    11,189
    Rep Power
    19

    Default Re: Aplet not loading on java 1.7

    If you're forever cleaning cobwebs, it's time to get rid of the spiders.

  3. #3
    psbhat is offline Member
    Join Date
    Feb 2012
    Posts
    2
    Rep Power
    0

    Default Re: Aplet not loading on java 1.7

    Yes .. It is cross posted since i did not get any reply from other forums.

    Please let me know anybody has got answer for this weird problem.

  4. #4
    Alstair is offline Member
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    0

    Default Re: Aplet not loading on java 1.7

    Now it is mine too. DO you have any solution anyone please?

  5. #5
    Norm's Avatar
    Norm is online now Moderator
    Join Date
    Jun 2008
    Location
    Eastern Florida
    Posts
    16,607
    Rep Power
    23

    Default Re: Aplet not loading on java 1.7

    java.net.MalformedURLException: no protocol:
    How are you building your URL that it doesn't have a protocol?

Similar Threads

  1. java aplet on firefox error
    By mike_ledis in forum Java Applets
    Replies: 1
    Last Post: 02-25-2011, 03:40 PM
  2. Java aplet keeps crashing
    By lojelo5 in forum Java Applets
    Replies: 1
    Last Post: 12-03-2010, 09:27 PM
  3. Java program is not loading
    By shoeb83 in forum New To Java
    Replies: 2
    Last Post: 12-29-2009, 02:15 AM
  4. Java Applet loading bar
    By genette in forum Java Applets
    Replies: 2
    Last Post: 12-27-2007, 03:39 AM
  5. Help with class loading in java
    By mathias in forum New To Java
    Replies: 1
    Last Post: 07-31-2007, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •