Results 1 to 2 of 2
  1. #1
    sup
    sup is offline Member
    Join Date
    Sep 2011
    Posts
    1
    Rep Power
    0

    Question Does Anyone know about compatibility between JDK version ?

    There are some question of JDK from me as follow, now I am testing program that compile with JDK1.6 Update 25
    While I have to test with update 22, is there are problem as follow;

    - Can we use lower JDK update to compile with higher JDK update library?
    - Can we run higher JDK update lib on lower JRE update?

  2. #2
    Tolls is offline Moderator
    Join Date
    Apr 2009
    Posts
    12,165
    Rep Power
    20

    Default Re: Does Anyone know about compatibility between JDK version ?

    You can run a higher on a lower for a particular Java version. They are supposed to be compatible, and I can't think of an instance offhand where that hasn't been the case.
    You can't run a 1.6 compiled version on a 1.5 JRE, though.

Similar Threads

  1. Compatibility issue
    By Borss in forum New To Java
    Replies: 0
    Last Post: 03-19-2011, 08:42 PM
  2. java -version pointing to older version
    By deepakts in forum New To Java
    Replies: 4
    Last Post: 05-06-2010, 10:59 AM
  3. need some compatibility information
    By wildheart25c in forum CLDC and MIDP
    Replies: 0
    Last Post: 04-25-2010, 08:29 AM
  4. Compatibility issues with IE7
    By Aneesha in forum New To Java
    Replies: 7
    Last Post: 11-30-2007, 06:46 AM
  5. Replies: 1
    Last Post: 08-09-2007, 08:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •