Hello,

Recently after hearing that Java 7 SE has been released, I downloaded it and installed it, but it didnt seem that my computer has been using it, since sometimes when giving me errors it related them to Java 6 SE. So I messed with the java files in the Program Files and Program Files (x86), like to delete the 6 version and leave the 7, but still didnt work. I tried to uninstall Java 6 JDK completely from the Programs & Feature in the Control Panel, but then all I could get was an error which is the following
Error 1723. There is a problem with this windows installer package. A DLL required for this install to complete could not be run. Contact you support personnel or package vendor.
When i googled the problem, I found a post in a forum saying to use a tool named JavaRa which supposedly removes old versions of java, but it only removes the JRE, I then downloaded the JRE of Java 7 only, to see if this works or not, but still i get same error for some tools which require java.

If there is someone who had this problem and now got it fixed, please I need your help.

Regards,