Results 1 to 2 of 2
  1. #1
    ssaitala is offline Member
    Join Date
    Sep 2013
    Posts
    1
    Rep Power
    0

    Default Eclipse Tomcat Plugin not deploying my maven dynamic web application.

    Hi,

    I use the below environment for eclipse tomcat plugin.

    I had a weird problem. I had a maven dynamic web application along with eclipse tomcat plugin. Eclipse tomcat plugin is able to detect
    my project from add/remove. After I have added my application into the tomcat with add/remove projects, I tried to restart my server. But ironically, though the web application is still there in add/remove, the tomcat is not deploying my web application. It is only starting my tomcat server. And ideas/suggestions on it is appreciated.

    OS: Windows 7 Professional
    tomcat version: 6.0.35
    Eclipse version: Juno
    maven dynamic web app facets:

    <faceted-project>
    <installed facet="java" version="1.6"/>
    <installed facet="jst.web" version="2.5"/>
    <installed facet="wst.jsdt.web" version="1.0"/>
    </faceted-project>

  2. #2
    gimbal2 is offline Just a guy
    Join Date
    Jun 2013
    Location
    Netherlands
    Posts
    3,756
    Rep Power
    5

    Default Re: Eclipse Tomcat Plugin not deploying my maven dynamic web application.

    - check the project build path if there are no weird exclusions in there
    - check the project deployment assembly to be sure that the proper resources are actually being deployed to the proper location
    - Eclipse is deploying the application to SOMEWHERE; figure out where and see if your project's deployable files are actually there

    You can get specific deployment configuration settings by double clicking on the server in your Eclipse servers view.
    "Syntactic sugar causes cancer of the semicolon." -- Alan Perlis

Similar Threads

  1. Maven plugin for eclipse 3.3.2
    By nareyugam in forum Apache Maven
    Replies: 3
    Last Post: 08-22-2013, 08:47 AM
  2. Replies: 0
    Last Post: 04-20-2009, 06:26 PM
  3. Maven 1.12 plugin in Eclipse 3.4
    By david.araujo in forum Eclipse
    Replies: 0
    Last Post: 02-12-2009, 07:10 AM
  4. Replies: 1
    Last Post: 10-05-2008, 11:09 AM
  5. Tomcat plugin for Eclipse
    By Java Tip in forum Java Tip
    Replies: 0
    Last Post: 01-16-2008, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •