Results 1 to 2 of 2
  1. #1
    Mate de Vita is offline Member
    Join Date
    Mar 2012
    Posts
    60
    Rep Power
    0

    Default Cannot run debugger - JVM error

    I can't run the Eclipse built-in debugger. When I try to do it, a message pops up, saying:
    'Launching Main' has encountered a problem.

    Cannot connect to VM
    socket closed
    The error that shows up in the Console is:
    FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
    The built-in Run works fine, and this happens with any program I try to debug.

    I've tried google, but mostly it was just Eclipse's required ports being blocked by Firewall, which is not the problem for me, since the same happens even if I turn off my Firewall.

    Any other solutions?

  2. #2
    Mate de Vita is offline Member
    Join Date
    Mar 2012
    Posts
    60
    Rep Power
    0

    Default Re: Cannot run debugger - JVM error

    Note: This happens if I try to debug as a Java Application. I've tried to debug as a Remote Java Application too, but that gives me the error:
    Failed to connect to remote VM. Connection refused.Connection refused: connect
    The port that Eclipse is supposed to use for debugging (127.0.0.1:8000) seems to be free with the netstat command.

Similar Threads

  1. Eclipse Debugger
    By sliminem in forum New To Java
    Replies: 2
    Last Post: 08-15-2011, 07:54 PM
  2. Eclipse debugger.
    By robc in forum Eclipse
    Replies: 0
    Last Post: 06-02-2010, 11:01 PM
  3. XML debugger in eclipse
    By bichi59 in forum Eclipse
    Replies: 0
    Last Post: 01-29-2009, 08:22 AM
  4. JS Debugger
    By jSarK0Y in forum Forum Lobby
    Replies: 0
    Last Post: 07-21-2008, 09:50 PM
  5. Help with debugger!!
    By anatel24 in forum New To Java
    Replies: 1
    Last Post: 04-07-2008, 03:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •