I'm working in Eclipse Indigo. I try an example StringSwitchDemo from the "Learning the Java Language > Language Basics" (The switch Statement (The Java™ Tutorials > Learning the Java Language > Language Basics)) but the lesson says it must be in Java SE 7 and later. So when I create the Java Proyect I select JavaSE-17 in "Use an excecution environment JRE". But it gives me an error. What I'm doing wrong?