Results 1 to 1 of 1
  1. #1
    gopikrish81 is offline Member
    Join Date
    Sep 2011
    Posts
    6
    Rep Power
    0

    Default Authentication for user weblogic denied

    When I try to start WebLogic using the command "startWebLogic.cmd" from my domain home, I am getting the below error, that I pasted from AdminServer.log file.

    But before pasting the error, let me tell something that I have to do in order to proceed further.

    After "startWebLogic.cmd" is given, there is no progress at all, and I need to press "quit" for further action.
    Since I couldn't see where exactly its stopping, I enabled "echo" in some of the .cmd's and this time I see the below (note: not pasted everything but I pasted the output just before it has stopped executing)

    C:\bea\user_projects\domains\myPortalDomain>"C:\be a\JROCKI~1\bin\java" com.point
    base.net.netServer /port:9092 /d:3 /pointbase.ini="C:\bea\wlserver_10.3\samples\
    domains\wl_server\pointbase.ini"
    Server started, listening on port 9092, display level: 3 ...



    So its stopping at this point, and I have to enter "quit", but I guess that is stopping the pointbase server.

    I even added GOTO :EOF in "startPointBase.cmd" after Pointbase is called like below, but still its not proceeding after > (greater than symbol)

    @rem Start PointBase
    "%JAVA_HOME%\bin\java" com.pointbase.net.netServer /port:9092 /d:3 /pointbase.ini="%SAMPLES_HOME%\domains\wl_server\po intbase.ini"

    GOTO :EOF

    :EOF

    Now, coming back to the error that I am getting, its pasted below...

    java.sql.SQLException: [Security:090735]The DBMS connection was not usable
    at weblogic.security.providers.authentication.DBMSSQL AuthenticatorDelegateImpl.getManageableConnection( DBMSSQLAuthenticatorDelegateImpl.java:923)
    at weblogic.security.providers.authentication.DBMSSQL AuthenticatorDelegateImpl.validateConfiguration(DB MSSQLAuthenticatorDelegateImpl.java:153)
    at weblogic.security.providers.authentication.DBMSSQL AuthenticatorDelegateImpl.<init>(DBMSSQLAuthentica torDelegateImpl.java:78)
    at weblogic.security.providers.authentication.DBMSAut henticatorDelegateImpl.getInstance(DBMSAuthenticat orDelegateImpl.java:459)
    at weblogic.security.providers.authentication.DBMSSQL AuthenticationProviderImpl.initialize(DBMSSQLAuthe nticationProviderImpl.java:56)
    at com.bea.common.security.internal.legacy.service.Se curityProviderImpl.init(SecurityProviderImpl.java: 65)
    at com.bea.common.engine.internal.ServiceEngineImpl.f indOrStartService(ServiceEngineImpl.java:363)
    at com.bea.common.engine.internal.ServiceEngineImpl.f indOrStartService(ServiceEngineImpl.java:315)
    at com.bea.common.engine.internal.ServiceEngineImpl.l ookupService(ServiceEngineImpl.java:257)
    at com.bea.common.engine.internal.ServicesImpl.getSer vice(ServicesImpl.java:72)
    at weblogic.security.service.internal.WLSIdentityServ iceImpl.initialize(Unknown Source)
    at weblogic.security.service.CSSWLSDelegateImpl.initi alizeServiceEngine(Unknown Source)
    at weblogic.security.service.CSSWLSDelegateImpl.initi alize(Unknown Source)
    at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.InitializeServiceEngine(Unknown Source)
    at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.initializeRealm(Unknown Source)
    at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.loadRealm(Unknown Source)
    at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.initializeRealms(Unknown Source)
    at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.initialize(Unknown Source)
    at weblogic.security.service.SecurityServiceManager.i nitialize(Unknown Source)
    at weblogic.security.SecurityService.start(SecuritySe rvice.java:141)
    at weblogic.t3.srvr.SubsystemRequest.run(SubsystemReq uest.java:64)
    at weblogic.work.ExecuteThread.execute(ExecuteThread. java:201)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java :173)

    ####<Sep 30, 2011 7:07:37 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389857978> <BEA-090075> <The SAMLIdentityAssertor provider has had its LDIF information loaded from: C:\bea\user_projects\domains\myPortalDomain\securi ty\SAMLIdentityAssertorInit.ldift>
    ####<Sep 30, 2011 7:07:38 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389858245> <BEA-090851> <The SAMLIdentityAsserter provider is initialized.>
    ####<Sep 30, 2011 7:07:38 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389858920> <BEA-090516> <The CredentialMapper provider has preexisting LDAP data.>
    ####<Sep 30, 2011 7:07:39 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389859659> <BEA-090516> <The Authorizer provider has preexisting LDAP data.>
    ####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861370> <BEA-090075> <The SAMLCredentialMapper provider has had its LDIF information loaded from: C:\bea\user_projects\domains\myPortalDomain\securi ty\SAMLCredentialMapperInit.ldift>
    ####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861480> <BEA-090851> <The SAMLCredentialMapperV2 provider is initialized.>
    ####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861559> <BEA-090516> <The CredentialMapper provider has preexisting LDAP data.>
    ####<Sep 30, 2011 7:07:41 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389861669> <BEA-090516> <The RoleMapper provider has preexisting LDAP data.>
    ####<Sep 30, 2011 7:07:42 PM IST> <Info> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389862203> <BEA-090093> <No pre-WLS 8.1 Keystore providers are configured for server AdminServer for security realm myrealm.>
    ####<Sep 30, 2011 7:07:42 PM IST> <Notice> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389862203> <BEA-090082> <Security initializing using security realm myrealm.>
    ####<Sep 30, 2011 7:07:58 PM IST> <Error> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389878205> <BEA-000000> <[Security:090735]The DBMS connection was not usable>
    ####<Sep 30, 2011 7:07:58 PM IST> <Critical> <Security> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <1317389878283> <BEA-090403> <Authentication for user weblogic denied>
    ####<Sep 30, 2011 7:07:58 PM IST> <Critical> <WebLogicServer> <AdminServer> <Main Thread> <<WLS Kernel>> <1317389878299> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
    weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
    at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.doBootAuthorization(Unknown Source)
    at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.initialize(Unknown Source)
    at weblogic.security.service.SecurityServiceManager.i nitialize(Unknown Source)
    at weblogic.security.SecurityService.start(SecuritySe rvice.java:141)
    at weblogic.t3.srvr.SubsystemRequest.run(SubsystemReq uest.java:64)
    at weblogic.work.ExecuteThread.execute(ExecuteThread. java:201)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java :173)

    How to resolve this please?
    Last edited by gopikrish81; 10-03-2011 at 06:55 AM. Reason: mistake

Similar Threads

  1. Access share folder with user authentication
    By kaswan_savita in forum SWT / JFace
    Replies: 1
    Last Post: 04-01-2011, 08:50 PM
  2. Replies: 3
    Last Post: 02-18-2011, 11:31 AM
  3. Migrating Application from weblogic 8.1 to weblogic 10.0 - Urgent
    By phanindar in forum Enterprise JavaBeans (EJB)
    Replies: 3
    Last Post: 01-07-2011, 08:47 PM
  4. Single user Login authentication
    By vinoopraj in forum Web Frameworks
    Replies: 0
    Last Post: 07-20-2010, 08:19 AM
  5. Replies: 2
    Last Post: 05-18-2010, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •