Hi,

I am working on extending the default Eclipse XML Editor adding some features to org.eclipse.wst.xml.ui plug-in.

When I run it from Eclipse using "Run as Eclipse Application" it works fine and I have all features I have implemented.

So I tried to install it putting the exported JAR file in the "dropins" folder.

Plug-in name is: org.eclipse.wst.xml.ui_v2.0.0XYZ where XYZ is the plug-in qualifier; the default plug-in name is org.eclipse.wst.xml.ui_v1.2.2XYZ.

I read that if Eclipse finds two plug-ins having the same name it should load the newer one but in my case it always loads the default one...why?

Thanks
Marco