I'm using Eclipse under Ubuntu 10.4 64 bit with an Intel x86 CPU. The download instructions are about 5 years old and don't mention Ubuntu or x86 64 bit. I'm a bit new to all this. Java is SE.

Any ideas of how I should do the install would be appreciated.

TIA, Nate