Results 1 to 4 of 4

Thread: Wrong settings?

  1. #1
    RonM is offline Member
    Join Date
    Aug 2009
    Posts
    3
    Rep Power
    0

    Default Wrong settings?

    Hello all,

    I have to make changes on an exsisting java project.
    All I know its that it was developt using eclips and java version 5.
    After import and recompiling I have hunderts of errors messages.
    Exemples:
    1. In the Line "private List<SpmlObject> mySpmls;" i get the message "Syntax error on token "<", "Identifier" expected"
    2. On override "@Override
    public String toString() {
    " I get the message "Syntax error on token "Invalid Character"..." on the "@".
    What I'm doing wrong? Wrong settings?

    Thanks

    Ron

  2. #2
    vkorenev is offline Member
    Join Date
    Aug 2009
    Location
    Kharkov, Ukraine
    Posts
    29
    Rep Power
    0

    Default

    This means that you are trying to compile your code either with pre-Java5 JDK (1.4 or older) or you passed "-source 1.4" option to the compiler.

  3. #3
    vogella is offline Member
    Join Date
    Aug 2009
    Location
    Heidelberg
    Posts
    47
    Rep Power
    0

    Default

    Eclipse has also a setting in preference where you can set the default JRE version to compile against.

    See Window -> Preferences -> Java -> Compiler -> Compiler compliance level

  4. #4
    RonM is offline Member
    Join Date
    Aug 2009
    Posts
    3
    Rep Power
    0

    Default

    Tanks for help, I have found the problem.
    I used an old version of eclipse max compiler compliance level = 1.4!
    Now I updated my eclipse version and every thing is working fine.

    Thanks

    Ron

Similar Threads

  1. Avoid using systems DPI settings ?
    By rolfius in forum AWT / Swing
    Replies: 5
    Last Post: 08-03-2009, 04:12 AM
  2. problem with odbc settings
    By nishant.4545 in forum Advanced Java
    Replies: 0
    Last Post: 08-02-2009, 04:14 PM
  3. settings to make in eclipse for first use?
    By junaidjee in forum Eclipse
    Replies: 1
    Last Post: 01-27-2009, 02:25 PM
  4. User settings
    By 3speed in forum New To Java
    Replies: 8
    Last Post: 10-31-2008, 12:53 PM
  5. Graphic settings being overridden?
    By sjchase in forum New To Java
    Replies: 0
    Last Post: 01-17-2008, 12:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •